Настрйока IPTV на роутере Mikrotik

30 posts in this topic

Я отмучался, то есть, настроил :)

 

 


/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=\
   ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=\
   ether4-slave-local
/ip neighbor discovery
set ether1-gateway discover=no
/interface bridge filter
add action=drop chain=output out-interface=wlan1 packet-type=multicast
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan1
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=\
   established,related
add chain=input protocol=igmp
add chain=input protocol=udp
add chain=forward protocol=udp
add chain=input comment="default configuration" in-interface=ether1-gateway
add action=fasttrack-connection chain=forward comment="default configuration" \
   connection-state=established,related
add chain=forward comment="default configuration" connection-state=\
   established,related
add action=drop chain=forward comment="default configuration" connection-state=\
   invalid
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
   out-interface=ether1-gateway
add action=masquerade chain=srcnat comment="default configuration" \
   out-interface=ether1-gateway to-addresses=0.0.0.0
/routing igmp-proxy
set query-interval=30s query-response-interval=20s
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1-gateway upstream=yes
add alternative-subnets=0.0.0.0/0 interface=bridge-local

 

Подтверждаю, рабочий вариант. При моей конфигурации если сбриджевать порт под IPTV и WAN, т.е. сделать формально хаб - падала вся сеть с вай-фай. Минут за 10 тщательно взгляд пронесся по всем строчкам кода, немалая часть их к IPTV отношение имеет косвенное, в первую очередь для настройки роутера с нуля (у меня hAP AC). Процентов 90% у меня уже лежало в настройке. Исправилось интервальное время, добавилась вторая строчка маскарада и правило в файерволл

add chain=input comment="default configuration" in-interface=ether1-gateway

и в этом правиле у меня не была прописана подсеть альтернативная

add alternative-subnets=0.0.0.0/0 interface=bridge-local

 

Всего этого не написано в большинстве хауту, которые повстречались при гуглении. Хотя везде примерно одинаковый ход мысли. Ставим пакет, задаем правила в IGMP Proxy и Firewall и наслаждаемся ТВ.

 

Добавилось и всё завелось прям отлично без фризов, рассыпания картинки и т.д.

 

Что касается вай-фай - скорость режется. Засекалось на frequency 5Ghz. При включенной IPTV падает с 60 Мб/сек до 45 Мб/сек.

При этом dashboard роутера говорит, что "я мол вообще не напрягся, вовсе". Я из тех людей, которые совсем не пользуются IPTV. Привязался ко мне с интернетом в общем пакете по не самой высокой цене. Можно было и не настраивать, но раз есть услуга хотелось иметь возможность ее использовать. Больше нравится Android TV Box.

 

А ведь еще немного и купился бы физический хаб/свич.

 

Кто-нить знает на чудо-пульте от онлайм есть что-то вроде кнопки Source?

 

Автору настройки, не поленившемуся выложить нюансы +1 в карму.

0

Поделиться этим ответом


Link to post
Share on other sites
чтоб процессор меньше был загружен, лучше вместо моста использовать мощности свитча. ether1 - мастер для ether5. ну а локалку уже в мост.
Наконец-то дошли руки проверить твой метод. Он работает, квадраты исчезли. Во вложении скриншот с настройками если кому надо.

Китти62, не советую пульт перенастраивать. Я донастраивал до такого, что телик от него работать стал, а приставка после загрузки отвлекаться переставала. Инженеры извинились, за то что дали мне инструкцию с настройками и заменили бесплатно. :)

П.С. телевизор ВВК

post-36134-1475862161.png

Изменено пользователем F_L
0

Поделиться этим ответом


Link to post
Share on other sites

Вот так ведёт себя в нашей сети 2011, как видно из скриншота, процессор почти не загружен. В принципе 751-ый даже при загрузке в 100% вёл себя как будто не загруженный, этот - просто идеал. Максимум чего я добился это 50% загрузки проца. Отличное решение.

post-36134-1476628327_thumb.png

0

Поделиться этим ответом


Link to post
Share on other sites
Наконец-то дошли руки проверить твой метод. Он работает, квадраты исчезли. Во вложении скриншот с настройками если кому надо.

 

Мои нейроны изначально так хотели сделать, но не поняли как после Quick Set'a выдернуть 1 порт из свитча и приписать его к воротам. На манипуляции

 

Глядя на скриншот до меня дошло: чтобы раздербанить свитч нужно во всех физических портах поле Master Port обозначить как 'none'.

 

После этого все получилось. Ранее когда после стандартных установок у меня не получалось раздербанить свитч, настройка пошла по ошибочному пути, описанному в большинстве мануалов.

 

Сейчас роутер не грузится выше 10% в простое с включенным ТВ (до этого было 50%) В нагрузке 40% максимум, ранее доходило до 100%. Правда 5Ghz сеть не выдает выше 70 Мб. Есть идеи на эту тему?

 

F_L Пульт перепрописался на новый ТВ марки LG, а ответ на мой вопрос: это делает кнопка A/V.

0

Поделиться этим ответом


Link to post
Share on other sites
Правда 5Ghz сеть не выдает выше 70 Мб. Есть идеи на эту тему?
А по какой причине длинна волны, должна влиять на скорость передачи данных? То, что там написано 5, вместо 2,4 абсолютно не значит, что скорость будет выше.

Я на 2,4 , на телефоне получаю 60. Всё ОК.

F_L Пульт перепрописался на новый ТВ марки LG, а ответ на мой вопрос: это делает кнопка A/V.
Ну я не сомневаюсь, что тут дело в частотах ИК порта. Так что с "лыжой" вполне реально, что всё прошло отлично и мой случай индивидуален. Но всё равно я предостерегаю от этого. В своём случае я воспользовался этим.
0

Поделиться этим ответом


Link to post
Share on other sites
То, что там написано 5, вместо 2,4 абсолютно не значит, что скорость будет выше.

 

По идее длина волны не должна влиять на скорость, на моей памяти у 5Ghz она короче в разы. Влиять может шум соседних точек доступа и на сколько я понимаю 5Ghz по факту зашумлен меньше. Не владею экспертизой в этой области, но ожидалось увидеть на 5GHz значение близкое хотя бы к 90 mb/sec (max по тарифу 100 mb/sec). На 2.4 не получилось пока выжать больше 30-40 mb/sec, что тоже не совсем удовлетворительно. Думаю попробовать перевести работу в режим "Only N", но не думаю что это даст какие-то результаты. У меня несколько устройств дома, которые работаю по wi-fi.

По проводу скорость 94-95 mb/sec.

Мой мобильный на 2.4 выжимает 30 mb/sec,

планшет - 20 mb/sec,

мобильный Asus вообще чудил и на сети 2,4 не выдавал более 1,5 mb/sec (режим n поддерживает).

 

При этом нагрузка на ЦП минимальная, идеи пока не посетили меня( Препятствий физических между устройством и роутером нет. Расстояние метр.

0

Поделиться этим ответом


Link to post
Share on other sites

Это называется оффтопик Китти. Модераторы, разделите тему, я думаю в соседней ветке ей обязательно ответят.

0

Поделиться этим ответом


Link to post
Share on other sites
оффтопик

 

Это не оффтоп. Это результаты и побочные эффекты после настройки сабжа! А вот Ваше замечание уже оффтоп. Больше интересует, есть какие-то варианты улучшить ситуацию.

0

Поделиться этим ответом


Link to post
Share on other sites

девочки, не ссорьтесь! вообще вся тема оффтоп))

0

Поделиться этим ответом


Link to post
Share on other sites
В 21.05.2016 в 20:48, adav сказал:

 

Будет, только не в vlan, а в бридж. При этом не забыть этот интерфейс 4LAN отвязать от master- порта, если он был там, иначе не даст сделать эту операцию. Можно создать еще одну локальную подсеть (аналогично основной), куда включить только 4 порт и на него завернуть igmр proxy. Тогда не будет мультикаст гадить по остальным портам и не потребуется получать еще один адрес от Онлайма на приставку.

Понравилось предложенное решение, но до конца его не смог понять и сделать, вы не могли бы пояснить? 

Стоит Mikrotik HAP AC, RouterOS 43.2

Сделал только это:

Цитата

Будет, только не в vlan, а в бридж. При этом не забыть этот интерфейс 4LAN отвязать от master- порта, если он был там, иначе не даст сделать эту операцию.

Привязки к master - порту в последних версиях RouterOS, насколько я понял,уже нет, поэтому просто убрал 4LAN из основного bridge  и объединил его вместе с WAN+LAN1 в новый bridge_iptv, все настройки bridge_iptv по умолчанию. Больше ничего не делал, при этом на ТВ сигнал пошел заработал, а WiFi перестал выдавать интернет.

Вы не могли бы по шагам расписать что нужно еще сделать?

Заранее спасибо!

 

0

Поделиться этим ответом


Link to post
Share on other sites

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти