Настрйока IPTV на роутере Mikrotik

30 posts in this topic

Очень нужна помощь с настройкой IPTV мультикаста на роутере Mikrotik. По найденному на просторах интернете мануалу (http://asp24.com.ua/blog/nastrojka-mikrotik-routeros-dlja-prosmotra-iptv-ot-provajdera/) самостоятельно настроить не получается. Возможно необходимо указывать другие данные при настройке. Если кто смог решить данную проблему, буду крайне признателен за помощь.

0

Поделиться этим ответом


Link to post
Share on other sites
Очень нужна помощь с настройкой IPTV мультикаста на роутере Mikrotik. По найденному на просторах интернете мануалу (http://asp24.com.ua/blog/nastrojka-mikrotik-routeros-dlja-prosmotra-iptv-ot-provajdera/) самостоятельно настроить не получается. Возможно необходимо указывать другие данные при настройке. Если кто смог решить данную проблему, буду крайне признателен за помощь.

 

Интерфейсы правильно установили? Пакеты на вкладке MFC в IGMP Proxy идут? с отключенным файрволлом пробовали?

посмотрите еще тут

http://www.lanta-net.ru/manual/cifrovoe-te...utera-mikrotik/

Изменено пользователем Valter
0

Поделиться этим ответом


Link to post
Share on other sites
Очень нужна помощь с настройкой IPTV мультикаста на роутере Mikrotik. По найденному на просторах интернете мануалу (http://asp24.com.ua/blog/nastrojka-mikrotik-routeros-dlja-prosmotra-iptv-ot-provajdera/) самостоятельно настроить не получается. Возможно необходимо указывать другие данные при настройке. Если кто смог решить данную проблему, буду крайне признателен за помощь.

 

 

 

Добрый день, к сожалению, мы не сможем помочь вам в данном вопросе, так как не владеем информацией подобного рода.

0

Поделиться этим ответом


Link to post
Share on other sites

Я отмучался, то есть, настроил :)

 

Mikrotik у меня модель hap lite, использовал утилиту winbox

 

Обновил прошивку (System-Packages-Auto update-Check for updates)

Это нужно, чтобы не заморачиваться с поиском следующего пункта под вашу прошивку

 

Скачал пакет Multicast (extra packages)

http://www.mikrotik.com/download (в моем случае smips, версия 6.34.2)

 

Далее, распаковав архив, найти в нём файл multicast-xx-xxxx.npk и подключится к маршрутизатору. При помощи фирменной утилиты Winbox, нужно переместить его (Drag&Drop) в окно раздела меню Files, как показано на изображении ниже.

 

Теперь надо перегрузить маршрутизатор, System – Reboot

 

После перезагрузки, мы опять подключаемся к маршрутизатору, где в разделе System – Packeges, мы должны увидеть установленный ранее пакет Multicast.

 

После этого я перерыл кучу инструкций, наконец, все заработало. Вот мой конфиг, через терминал winbox'a можно просто скопировать эти команды в окно терминала, и у вас появятся эти настройки:

 


/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=\
   ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=\
   ether4-slave-local
/ip neighbor discovery
set ether1-gateway discover=no
/interface bridge filter
add action=drop chain=output out-interface=wlan1 packet-type=multicast
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=wlan1
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=\
   established,related
add chain=input protocol=igmp
add chain=input protocol=udp
add chain=forward protocol=udp
add chain=input comment="default configuration" in-interface=ether1-gateway
add action=fasttrack-connection chain=forward comment="default configuration" \
   connection-state=established,related
add chain=forward comment="default configuration" connection-state=\
   established,related
add action=drop chain=forward comment="default configuration" connection-state=\
   invalid
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" \
   out-interface=ether1-gateway
add action=masquerade chain=srcnat comment="default configuration" \
   out-interface=ether1-gateway to-addresses=0.0.0.0
/routing igmp-proxy
set query-interval=30s query-response-interval=20s
/routing igmp-proxy interface
add alternative-subnets=0.0.0.0/0 interface=ether1-gateway upstream=yes
add alternative-subnets=0.0.0.0/0 interface=bridge-local

 

(Если есть какие-то запрещающие правила в файрволле, то добавляемые разрешающие правила должны быть выше их, если нет, просто можно перетащить наверх)

 

Плюс, при данной настройке не должна резаться скорость wifi

 

 

Техподдержка могла бы уже давно себе найти инструкцию, раз у людей вопросы появляются.

0

Поделиться этим ответом


Link to post
Share on other sites
А еще, говорят, можно хаб воткнуть сразу на входе в квартиру - а в него роутер и приставку.

 

Тогда роутер не будет влиять на IPTV.

 

И вообще ничего настраивать не нужно.

 

 

можно и так, но было только одно устройство под рукой :) имхо схему с хабом и роутером имеет смысл реализовывать когда больше 1 телевизора использует интерактивное тв, тут мощности роутера может не хватить, если включить все одновременно

 

ну или схему с двумя роутерами, один в качестве роутера, другой в режиме точки доступа.

 

роутер ос позволяет все настроить красиво и безопасно, правда, неочевидно. с точки зрения клиентоориентированности техподдержки самым лучшим было бы выкатить готовый скрипт настроек микротика, благо, что от версии к версии они отличаться не будут, и инструкцию по добавлению пакета

 

Да, микротики не так популярны, но на форуме навскидку я нашел несколько тем без четкого решения

0

Поделиться этим ответом


Link to post
Share on other sites
А еще, говорят, можно хаб воткнуть сразу на входе в квартиру - а в него роутер и приставку.

 

Тогда роутер не будет влиять на IPTV.

 

И вообще ничего настраивать не нужно.

 

А если WAN и, например, четвертый LAN порт роутера объединить в одну VLAN, -- это не будет эквивалентно установке свитча перед роутером?

Изменено пользователем bugmenot
0

Поделиться этим ответом


Link to post
Share on other sites
А если WAN и, например, четвертый LAN порт роутера объединить в одну VLAN, -- это не будет эквивалентно установке свитча перед роутером?

 

Будет, только не в vlan, а в бридж. При этом не забыть этот интерфейс 4LAN отвязать от master- порта, если он был там, иначе не даст сделать эту операцию. Можно создать еще одну локальную подсеть (аналогично основной), куда включить только 4 порт и на него завернуть igmр proxy. Тогда не будет мультикаст гадить по остальным портам и не потребуется получать еще один адрес от Онлайма на приставку.

1

Поделиться этим ответом


Link to post
Share on other sites
Можно создать еще одну локальную подсеть (аналогично основной), куда включить только 4 порт и на него завернуть igmр proxy

Сделал по вашему совету - что-то не завелось... Может быть, в эту новую локальную подсеть надо как-то завести интернет?

 

П.С. Когда просто перевел LAN4 в одну VLAN c WAN-портом, то работает.

 

П.П.С. "Завелось" по вашей схеме (отдельная подсеть) когда отключил/подключил питание приставки! Спасибо за совет!

Изменено пользователем bugmenot
0

Поделиться этим ответом


Link to post
Share on other sites
А еще, говорят, можно хаб воткнуть сразу на входе в квартиру - а в него роутер и приставку.

 

Вот, как раз лопачу форум, пытаюсь понять — есть ли в этом смысл с точки зрения облегчения жизни роутеру (ему, помимо приставки, приходится тащить на себе 3-4 беспроводных клиентов, 1 SIP телефон, 2 компа по проводу)? А то надо один порт освободить. Хаб? Свитч? Как это вообще будет работать (будет ли?)

0

Поделиться этим ответом


Link to post
Share on other sites

Вообще интересно, позвонили, предложили услугу айпи-тв, рассказали как все будет хорошо - ок, пробуем. Специально спросил - нужен ли доступ в роутер или и так всё ок заведется, заверили - все ок, доступ в роутер не нужен, тока кабель воткнём. Хорошо. В итоге приехал монтажник, я на работе, он микротик видит первый раз и техподдержка онлайма ему помочь не может. Придется опять самостоятельно все настраивать :)

0

Поделиться этим ответом


Link to post
Share on other sites
есть ли в этом смысл с точки зрения облегчения жизни роутеру

10 Мбит - разве это серьезная нагрузка

0

Поделиться этим ответом


Link to post
Share on other sites
10 Мбит - разве это серьезная нагрузка

Для микротика это не проблема :D

0

Поделиться этим ответом


Link to post
Share on other sites

А как до автора дописаться, никто не знает?.. Не получается настроить по инструкции. (

0

Поделиться этим ответом


Link to post
Share on other sites
А как до автора дописаться, никто не знает?.. Не получается настроить по инструкции. (

в личку постучите ему. если недостучитесь, можно платную консультацию сделать (мне в личку, если заинтересованы)

0

Поделиться этим ответом


Link to post
Share on other sites

Ребята, а кто проблему QoS победил? Не могу. Когда Торрентом что-то качать начинаю приставку и как следствие изображение на телевизоре пикселизует и затыки каждую секунду.

Настройки простые, WAN - Eth1, STB - Eth5, Комп - Eth2

post-36134-1474390694_thumb.png

0

Поделиться этим ответом


Link to post
Share on other sites
Ребята, а кто проблему QoS победил? Не могу. Когда Торрентом что-то качать начинаю приставку и как следствие изображение на телевизоре пикселизует и затыки каждую секунду.

Настройки простые, WAN - Eth1, STB - Eth5, Комп - Eth2

Не судьбы в клиенте ограничение скорости поставить?

0

Поделиться этим ответом


Link to post
Share on other sites

Здорово ... а я-то думал, как-же мне в голову такая мысль пришла. Не помогает.

0

Поделиться этим ответом


Link to post
Share on other sites
Ребята, а кто проблему QoS победил? Не могу. Когда Торрентом что-то качать начинаю приставку и как следствие изображение на телевизоре пикселизует и затыки каждую секунду.

Настройки простые, WAN - Eth1, STB - Eth5, Комп - Eth2

чтоб процессор меньше был загружен, лучше вместо моста использовать мощности свитча. ether1 - мастер для ether5. ну а локалку уже в мост.

0

Поделиться этим ответом


Link to post
Share on other sites
чтоб процессор меньше был загружен ...
Дело в том, что как видно из скриншота, даже при полной загрузке канала нагрузка на проц. не поднимается и до 10%

Я уже сегодня думал вместо моста попробовать igmp proxy как себя будет везти.

В принципе и ваша идея тоже имеет место для проверки.

Не понятно где затык. Используя Keenetik Giga (первый релиз, последняя 2.* прошивка) раскидывая так конфигурацию, вообще проблем нет (загрузка проца 30% максимум). Эта железка на уровень мощнее, значит где-то что-то в настройках.

 

0

Поделиться этим ответом


Link to post
Share on other sites
Дело в том, что как видно из скриншота, даже при полной загрузке канала нагрузка на проц. не поднимается и до 10%

Я уже сегодня думал вместо моста попробовать igmp proxy как себя будет везти.

у меня есть опыт настройки тика под тв другого провайдера. тут я думаю также. при использовании igmp proxy тв взлетает с одним мостом для локалки. но если потребителей мультикаста будет более одного (приставки для iptv), то на экранах будет калейдоскоп из квадратов.

также не стоит забывать, что мультикаст полезет в wi-fi интерфейс, со всеми вытекающими последствиями.

Изменено пользователем Ni©olas
0

Поделиться этим ответом


Link to post
Share on other sites

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти