• Enigma

      Обновленный форум ОнЛайм   03/22/2017

      Уважаемые пользователи форума «ОнЛайм»! Благодаря Вашим отзывам мы модернизировали внешний вид форума. В данный момент интерфейс проходит этап пользовательского тестирования. Обо всех найденных ошибках Вы можете рассказать здесь, в ветке «Обратная связь», а также через кнопку «Пожаловаться». Благодаря Вам мы сделаем пребывание на форуме «ОнЛайм» комфортным и полезным. Спасибо за Ваше участие и внимание. 
Followers 0

Странное поведение соединений

17 posts in this topic

Приветствую!

Тут волей случая другого провайдера включил онлайм как основной на месячишко.

И понять не могу... то ли лыжи не едут, то ли...

Но в общем, со многими сайтами происходит очень долгое подключение. Именно на стадии установки соединения, доменное имя отресолвлено, т.е. выглядит как SYN пакеты уходящие в черную дыру.

После того, как соединение произошло - дальше все работает хорошо, т.е. новые соединения устанавливаются сразу.

И так с разными сайтами в разное время, но тенденция есть. Это не проблема сайтов, в тоже время, как у меня висит подключение, с других интернет каналов все уходит и коннектит сразу.

Потерь никаких нет, пингуется большими пакетами весь маршрут без проблем.

Это что-то известное или какая-то частная болезнь?

Edited by Terra Inc

Share this post


Link to post
Share on other sites

А установка соединения происходит не в новом табе Гугл Хроме, случайно? У меня Гугл Хром на одном из РС тупит именно так :-\

Share this post


Link to post
Share on other sites

Подтверждаю, с пятницы, если не с четверга, начались проблемы - очень долгий ответ или таймаут для определенных сайтов, например, xkcd.com. Сайты живые, с сотового МТС или через VPN отвечают мгновенно, браузеры и DNS не причем - та же картина при телнете на 80й порт по ip адресу.

Share this post


Link to post
Share on other sites
А установка соединения происходит не в новом табе Гугл Хроме, случайно? У меня Гугл Хром на одном из РС тупит именно так :-\

Не только, увы. Обычный telnet на этот IP, причем напрямую с роутера (у меня роутер - linux) тоже затыкается.

Какой-то системы пока найти не удалось.

Share this post


Link to post
Share on other sites

Тоже заметил проблемы с четверга, снимал network trace, видно, что иногда долго нет ответа на SYN пакеты (доходит до 15-20 секунд).

 

При этом проблема касается только тех сайтов (а на самом деле IP адресов), с которыми давно не было соединений, и возникает не всегда.

И только с HTTP (port 80) - соединения по HTTPS никогда не "тормозят".

 

Подозреваю, что как и у многих провайдеров, весь исходящий TCP port 80 трафик "завернут" на пул обычных серверов с Линуксом для целей DPI, и, вероятно, один из этих серверов вышел из строя (чем и можно объяснить похожее поведение).

 

[upd] При этом с DNS проблем никаких нет - в трейсе ответ от DNS приходит мгновенно (используется 8.8.8.8 и 62.76.76.62).

Именно первое TCP соединение по 80 порту иногда проседает, при этом для популярных сайтов, где не включен HTTPS (livejournal, CNN, и т.п).

Edited by zero

Share this post


Link to post
Share on other sites

+1 при подключении ко многим сайтам такое, будто сначала секунд 5-10 не пингуется, а потом как подключение произошло - страницы открываются быстро, может это работа фаерволов на стороне ростелекома?

тот же самый спидтест при нажатии на кнопку "начать проверку" ждет секунд 5 перед тем как начать тест. На резервном провайдере такого нету, сразу запускается тест, и на тех же сайтах, которые долго открываются, на резерваном происходит моментальное подключение

Share this post


Link to post
Share on other sites

Было, проходили и обсуждали - поменяйте DNS на гугловские - 8.8.8.8 и 8.8.4.4

Share this post


Link to post
Share on other sites
Было, проходили и обсуждали - поменяйте DNS на гугловские - 8.8.8.8 и 8.8.4.4

в роутере или сетевой карте?

в сетевой карте прописал - ни чего не изменилось....

Share this post


Link to post
Share on other sites
Сразу на роутере

это как?, при смене dns отличного от того который выдает провайдер инет не грузится вообще

Share this post


Link to post
Share on other sites
это как?, при смене dns отличного от того который выдает провайдер инет не грузится вообще

Днс вообще не влияют на отсутствие наличие интернета. Скажем так... Они лишь транслируют цифровые имена(IP) сайтов, в имена вида samsic.com.

Share this post


Link to post
Share on other sites
Днс вообще не влияют на отсутствие наличие интернета. Скажем так... Они лишь транслируют цифровые имена(IP) сайтов, в имена вида samsic.com.

особо не разбираюсь, но как это не влияет?!?!?!? соединение ipoe - ip и dns выдаются автоматически и если я прописываю в ручную гугловские, то не одна страница не открывается и в браузере ошибка днс, или мы о разных вещах говорим?

Share this post


Link to post
Share on other sites
особо не разбираюсь, но как это не влияет?!?!?!? соединение ipoe - ip и dns выдаются автоматически и если я прописываю в ручную гугловские, то не одна страница не открывается и в браузере ошибка днс, или мы о разных вещах говорим?

Вот. Почитайте для понимания.

 

Share this post


Link to post
Share on other sites
особо не разбираюсь, но как это не влияет?!?!?!? соединение ipoe - ip и dns выдаются автоматически и если я прописываю в ручную гугловские, то не одна страница не открывается и в браузере ошибка днс, или мы о разных вещах говорим?

Скорее всего вы неправильно прописали DNS в настройках роутера.

Share this post


Link to post
Share on other sites
особо не разбираюсь, но как это не влияет?!?!?!? соединение ipoe - ip и dns выдаются автоматически и если я прописываю в ручную гугловские, то не одна страница не открывается и в браузере ошибка днс, или мы о разных вещах говорим?

Нужно чтобы была возможность прописать только DNS, а IP по прежнему должен получаться автоматически

Share this post


Link to post
Share on other sites
Скорее всего вы неправильно прописали DNS в настройках роутера.

подскажите как это сделать в микротике, поля не активны...

post-41617-1484236821_thumb.png

 

есть еще роутер, но там тоже свои dns выставляются только при выборе static

Share this post


Link to post
Share on other sites

Там не сложно. Последовательно по пунктам: IP - DNS на открывшейся вкладке

Servers нажали, откроется поле для ввода адреса сервера. После Apply и всё.

Адресов можно вбить несколько.

Удачи Вам.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Followers 0