RouterOS и mikrotik

81 posts in this topic

ruvhell что за тема с телевидением? нужен только роутер и плазма подключенная по витой? никаких больше коробочек и платить не нужно?

0

Поделиться этим ответом


Link to post
Share on other sites
ruvhell что за тема с телевидением? нужен только роутер и плазма подключенная по витой? никаких больше коробочек и платить не нужно?

yes!

0

Поделиться этим ответом


Link to post
Share on other sites
yes!

кстати вот

#EXTINF:0,Дождь
#EXTGRP:НОВОСТИ
http://slynet.8nio.com/mn/dozhd_sly.m3u8

Изменено пользователем ruvhell
0

Поделиться этим ответом


Link to post
Share on other sites

У меня давно уже отвалились все vpn интерфейсы. Пароли нормально парсятся и ложутся в роутер, скрипты в планировщике запускаются. Как чинить?

post-37205-1450714266.jpg

0

Поделиться этим ответом


Link to post
Share on other sites
У меня давно уже отвалились все vpn интерфейсы. Пароли нормально парсятся и ложутся в роутер, скрипты в планировщике запускаются. Как чинить?

post-37205-1450714266.jpg

нужно проверить, нет ли знака перехода строки в файле. И с какой ошибкой отваливается?

 

нужно проверить, нет ли знака перехода строки в файле. И с какой ошибкой отваливается?

 

:global newp [:pick [/file get [/file find name=vpnbook.txt] contents]  0 8];
:global oldp [/interface pptp-client get vpnbook.com password];
:if ($oldp != $newp) do {/interface pptp-client set vpnbook.com password=$newp};
:set newp;:set oldp;

0

Поделиться этим ответом


Link to post
Share on other sites

Вот нереально сложная задачка, которую умы в интернете пока изящно на RouterOS решить не смогли :)

 

Исходные данные: 2 аплинка от двух разных провайдеров по 100 Мбит/сек. В обоих случаях ethernet, по dhcp устройство получает реальный динамический IP, который меняется раз в сутки. Никаких PPP.

 

Задача:

1) настроить Load Balancing + Failover.

2) иметь возможность извне подключиться к роутеру как через первого, так и второго провайдера.

 

Вся фишка в том, что официальная документация и многочисленные статьи в Интернете описывают случаи, где интерфейсам назначается статический реальный IP адрес, заранее известен адрес шлюза по умолчанию (напомню, у нас динамический IP и каждый раз выдаётся из разного диапазона, например 108.209.10.0/24, 212.1.0.0/16 итп сети заранее неизвестные, каким будет адрес шлюза по умолчанию - мы тоже не знаем).

 

Если IP статические, всё элементарно: создаётся 2 таблицы маршрутизации, в которую добавляется 2 маршрута по умолчанию с разной метрикой (distance), далее маркируем трафик (routing mark) и отправляем в нужную таблицу.

А если IP динамические, то? :)

0

Поделиться этим ответом


Link to post
Share on other sites
Вот нереально сложная задачка, которую умы в интернете пока изящно на RouterOS решить не смогли :)

 

Исходные данные: 2 аплинка от двух разных провайдеров по 100 Мбит/сек. В обоих случаях ethernet, по dhcp устройство получает реальный динамический IP, который меняется раз в сутки. Никаких PPP.

 

Задача:

1) настроить Load Balancing + Failover.

2) иметь возможность извне подключиться к роутеру как через первого, так и второго провайдера.

 

Вся фишка в том, что официальная документация и многочисленные статьи в Интернете описывают случаи, где интерфейсам назначается статический реальный IP адрес, заранее известен адрес шлюза по умолчанию (напомню, у нас динамический IP и каждый раз выдаётся из разного диапазона, например 108.209.10.0/24, 212.1.0.0/16 итп сети заранее неизвестные, каким будет адрес шлюза по умолчанию - мы тоже не знаем).

 

Если IP статические, всё элементарно: создаётся 2 таблицы маршрутизации, в которую добавляется 2 маршрута по умолчанию с разной метрикой (distance), далее маркируем трафик (routing mark) и отправляем в нужную таблицу.

А если IP динамические, то? :)

 

 

Не уловил мысль в чем собственно проблема.

 

Исходные данные: 2 аплинка от двух разных провайдеров по 100 Мбит/сек. В обоих случаях ethernet, по dhcp устройство получает реальный динамический IP

 

2 аплинка - хорошо, разные провайдеры - отлично. Скорость 100 - а какая разница для настройки?

 

По DHCP получаем IP. В настройках DHCP клиента можем установить метрику дефолтного маршрута.

 

Если IP статические, всё элементарно:

1) создаётся 2 таблицы маршрутизации,

2) в которую добавляется 2 маршрута по умолчанию с разной метрикой (distance),

3) далее маркируем трафик (routing mark) и отправляем в нужную таблицу.

 

 

1) Создать 2 таблицы маршрутизации не проблема, для этого нужные аплинковые интерфейсы сразу помещаем в нужные VRF.

2) Зачем 2 маршрута по умолчание делать с разной метрикой, если они всё-равно в разных таблицах? Если только перекрестно для отказоустойчивости. Для этого делаем простенький скрипт для проверки значения IP адреса из таблицы. Дальше будет проще. Пример для первого аплинка ниже:

 

:local IP_ISP1

:local IP_ISP1 [ /ip address get [/ip address find interface="указать называние интерфейса" dynamic=yes] address ]

 

# Исключаем маску

:for i from=( [:len $IP_ISP1] - 1) to=0 do={

:if ( [:pick $IP_ISP1 $i] = "/") do={

:set IP_ISP1 [:pick $IP_ISP1 0 $i];

}

}

 

3) здесь всё стандартно.

 

 

 

 

иметь возможность извне подключиться к роутеру как через первого, так и второго провайдера.

 

DDNS в помощь

0

Поделиться этим ответом


Link to post
Share on other sites

как прописать чтобы скороть резалась после счкачанного гигабайта трафика до 64 кб

и еще после скачаных 500 мегов запрашивал страницу входа заново

 

Изменено пользователем Dimaker
0

Поделиться этим ответом


Link to post
Share on other sites

iptv как пробросить без прокси

0

Поделиться этим ответом


Link to post
Share on other sites

а если wan-порт и порт приставки объединить в бридж и повесить на него dhcp-client?

0

Поделиться этим ответом


Link to post
Share on other sites

Микротик рулит. :) Режет рекламу на тьюбике, еще кое-че полезное делает. Скорость балансирует.

0

Поделиться этим ответом


Link to post
Share on other sites

Попыталя поставить XUPNPD на Mikrotik RB951Ui-2HnD - ошибка при запуске (symbol 'stdout': can't handle reloc type 0x7e)

поставил METARouter, добавил Interface, поменял пароль для root, установил Webif с помощью Web-морды поставил vsftpd, и все пакеты указанные ruvhell-ом, залил распакованные файлы в usr/share, выставил атрибуты, при запуске любого - ошибки:

line 1: syntax error: "(" unexpected

или
symbol 'stdout': can't handle reloc type 0x7e

или
./xupnpd-bcm2708: line 1: syntax error: word unexpected (expecting ")")


подскажите что делаю не так? можете выложить рабочие файлы (openwrt и xupnpd)?

может есть аналоги xupnpd?

можно ли поставить из репозитория с помощью webif, тогда какой адрес репозитория?

может есть готовая сборка?
 

 

Изменено пользователем poskotinov_av
0

Поделиться этим ответом


Link to post
Share on other sites
2 часа назад, poskotinov_av сказал:

Попыталя поставить XUPNPD на Mikrotik RB951Ui-2HnD - ошибка при запуске (symbol 'stdout': can't handle reloc type 0x7e)

поставил METARouter, добавил Interface, поменял пароль для root, установил Webif с помощью Web-морды поставил vsftpd, и все пакеты указанные ruvhell-ом, залил распакованные файлы в usr/share, выставил атрибуты, при запуске любого - ошибки:

line 1: syntax error: "(" unexpected

или
symbol 'stdout': can't handle reloc type 0x7e

или
./xupnpd-bcm2708: line 1: syntax error: word unexpected (expecting ")")


подскажите что делаю не так? можете выложить рабочие файлы (openwrt и xupnpd)?

может есть аналоги xupnpd?

можно ли поставить из репозитория с помощью webif, тогда какой адрес репозитория?

может есть готовая сборка?
 

 

Что вы вообще пытаетесь в итоге получить? ....

 

0

Поделиться этим ответом


Link to post
Share on other sites
3 минуты назад, enzain сказал:

Что вы вообще пытаетесь в итоге получить? ....

 

DLNA сервер средствами роутера

0

Поделиться этим ответом


Link to post
Share on other sites
26 минут назад, poskotinov_av сказал:

DLNA сервер средствами роутера

О_о

Это ж роутер, а не медиасервер ... или я чего-то не понимаю ...

Метароутер то с чем установили? С опенврт каким нибудь?

0

Поделиться этим ответом


Link to post
Share on other sites
5 минут назад, enzain сказал:

О_о

Это ж роутер, а не медиасервер ... или я чего-то не понимаю ...

Метароутер то с чем установили? С опенврт каким нибудь?

Ога 

0

Поделиться этим ответом


Link to post
Share on other sites

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти