RouterOS и mikrotik

81 posts in this topic

роутер 951G-2HnD по wi-fi выдает практически обещенные 95 Мб, но это только на компьютере, причем стабильно, а с планшетов и телефонов скорость вроде бы как режиться и не поднимается выше 10 Мб, конечно это не критично но тем не менее, видимо что то нужно в настройках поменять...куда смотреть?

 

 

0

Поделиться этим ответом


Link to post
Share on other sites
роутер 951G-2HnD по wi-fi выдает практически обещенные 95 Мб, но это только на компьютере, причем стабильно, а с планшетов и телефонов скорость вроде бы как режиться и не поднимается выше 10 Мб, конечно это не критично но тем не менее, видимо что то нужно в настройках поменять...куда смотреть?

- я бы покопал в сторону возможности планшета\телефона обрабатывать такую скорость......

- скорость может проседать из-за того, что на одном канале сидит куча соседских сетей + мощность wi-fi адаптера ноута\системника гораздо больше мобильника\планшета

Изменено пользователем ruvhell
0

Поделиться этим ответом


Link to post
Share on other sites

А тем временем, Mikrotik анонсировали устройства мечты для дома в линейке hAP. В 3-м квартале эта линейка дополнится 2-мя устройствами с поддержкой 5 ГГц + 802.11ac

Т.о., эта линейка будет выглядеть так:

 

 

hAP = 2.4 ГГц, MIMO 2x2, 802.11n (b/g/n) + 650 MHz + 100Mbit + PoE (in/out) + USB

hAP ac lite = 2.4 ГГц, MIMO 2x2, 802.11n (b/g/n) + 5 ГГц, 1 канал, 802.11ac + 650 MHz + 100Mbit + PoE (in/out) + USB

hAP ac = 2.4 ГГц, MIMO 2x2, 802.11n (b/g/n) + 5 ГГц, 3 канала, 802.11ac + 720 MHz + 1000Mbit + PoE (in/out) + USB + SFP

 

 

0

Поделиться этим ответом


Link to post
Share on other sites
Добрый день!

 

после года использования - пришел к выводу, что приоритезация трафика снижает скорость скачивания торентов т.к. сильно грузит роутер. Соответсвенно, задизейблил в мангл все метки.

1 канал бесплатного pptp не стабилен, часто падает и слишком узок.

 

решил сделать Load Balancing через PCC (Per Connection Classifier) и Multiple Gateways

мануал http://wiki.mikrotik.com/wiki/Manual:PCC

Итак:

1)запасаемся бесплатными pptp и периодически проверяем новые пароли у них:

а)

curl -s "https://www.vpnme.me/freevpn.html" | grep -A 3 "Password:" | head -n 2 | cut -f2 -s -d "<" | cut -f2 -d ">" | grep -v -e '^$' > /tmp/vpnme.me.txt

б)

curl -s "http://www.vpnbook.com" | grep -A 1 "Username: vpnbook" | tail -n 1| cut -f2 -d " " | cut -f1 -d '<' | grep -v -e '^$' > /tmp/vpnbook.txt

в)

curl -s "http://freevpnaccess.com" | grep -A 8 "UK - London" | tail -n 1 | cut -f1 -d " " | tr -cd [:digit:] | grep -v -e '^$' >/tmp/freevpnaccess.com.txt

г)

curl -s "http://freevpn.me/accounts/" | grep -A 3 "Password:" | head -n 1 | cut -f2 -d ":" |cut -f2 -d ">" | cut -f2 -d " " | cut -f1 -d "<"| grep -v -e '^$' > /tmp/freevpn.me.txt

д)

curl -s "http://freecloudvpn.com" | grep -A 3 "Password:" | head -n 2 | cut -f4 -s -d " " | cut -f1 -d "<" | grep -v -e '^$' > /tmp/freecloudvpn.com.txt

 

2) далее делаем скрипт на закачивание полученных файликов на наш роутер и пихаем его в крон так же как и приведенные скриптики.

 

3) поднимаем новые pptp соединения на роутере

4) делаем новые правила в mangl для разбиения трафика по адрес-порту(я в туннель завернул еще и DNS):

/ip firewall mangle
add action=mark-connection chain=prerouting dst-address-list=russianbl \
    dst-address-type=!local new-connection-mark=Pcc_Conn_1 \
    per-connection-classifier=both-addresses-and-ports:5/0
add action=mark-connection chain=prerouting dst-address-list=russianbl \
    dst-address-type=!local new-connection-mark=Pcc_Conn_2 \
    per-connection-classifier=both-addresses-and-ports:5/1
add action=mark-connection chain=prerouting dst-address-list=russianbl \
    dst-address-type=!local new-connection-mark=Pcc_Conn_3 \
    per-connection-classifier=both-addresses-and-ports:5/2
add action=mark-connection chain=prerouting dst-address-list=russianbl \
    dst-address-type=!local new-connection-mark=Pcc_Conn_4 \
    per-connection-classifier=both-addresses-and-ports:5/3
add action=mark-connection chain=prerouting dst-address-list=russianbl \
    dst-address-type=!local new-connection-mark=Pcc_Conn_5 \
    per-connection-classifier=both-addresses-and-ports:5/4
add action=mark-connection chain=prerouting dst-port=53 new-connection-mark=\
    pptp protocol=tcp
add action=mark-connection chain=prerouting dst-port=53 new-connection-mark=\
    pptp protocol=udp
add action=mark-routing chain=prerouting connection-mark=pptp dst-port=53 \
    new-routing-mark=Route_1 protocol=udp
add action=mark-routing chain=prerouting connection-mark=pptp dst-port=53 \
    new-routing-mark=Route_1 protocol=tcp
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_1 \
    dst-address-list=russianbl dst-address-type=!local new-routing-mark=\
    Route_1
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_2 \
    dst-address-list=russianbl dst-address-type=!local new-routing-mark=\
    Route_2
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_3 \
    dst-address-list=russianbl dst-address-type=!local new-routing-mark=\
    Route_3
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_4 \
    dst-address-list=russianbl dst-address-type=!local new-routing-mark=\
    Route_4
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_5 \
    dst-address-list=russianbl dst-address-type=!local new-routing-mark=\
    Route_5

5) добавляем в NAT 4 правила для новых PPTP (1-е pptp из 1-го поста у нас уже есть)

6) строим дерево route в IP (пришлось вспомнить с комбинаторику)

 

/ip route
add check-gateway=arp distance=1 gateway=vpnbook.com routing-mark=Route_1
add check-gateway=arp distance=2 gateway=vpnme.me routing-mark=Route_1
add check-gateway=arp distance=3 gateway=freecloudvpn.com routing-mark=\
    Route_1
add check-gateway=arp distance=4 gateway=freevpn.me routing-mark=Route_1
add check-gateway=arp distance=5 gateway=freevpnaccess.com routing-mark=\
    Route_1
add check-gateway=arp distance=1 gateway=freevpnaccess.com routing-mark=\
    Route_2
add check-gateway=arp distance=2 gateway=vpnbook.com routing-mark=Route_2
add check-gateway=arp distance=3 gateway=vpnme.me routing-mark=Route_2
add check-gateway=arp distance=4 gateway=freecloudvpn.com routing-mark=\
    Route_2
add check-gateway=arp distance=5 gateway=freevpn.me routing-mark=Route_2
add check-gateway=arp distance=1 gateway=freevpn.me routing-mark=Route_3
add check-gateway=arp distance=2 gateway=freevpnaccess.com routing-mark=\
    Route_3
add check-gateway=arp distance=3 gateway=vpnbook.com routing-mark=Route_3
add check-gateway=arp distance=4 gateway=vpnme.me routing-mark=Route_3
add check-gateway=arp distance=5 gateway=freecloudvpn.com routing-mark=\
    Route_3
add check-gateway=arp distance=1 gateway=freecloudvpn.com routing-mark=\
    Route_4
add check-gateway=arp distance=2 gateway=freevpn.me routing-mark=Route_4
add check-gateway=arp distance=3 gateway=freevpnaccess.com routing-mark=\
    Route_4
add check-gateway=arp distance=4 gateway=vpnbook.com routing-mark=Route_4
add check-gateway=arp distance=5 gateway=vpnme.me routing-mark=Route_4
add check-gateway=arp distance=1 gateway=vpnme.me routing-mark=Route_5
add check-gateway=arp distance=2 gateway=freecloudvpn.com routing-mark=\
    Route_5
add check-gateway=arp distance=3 gateway=freevpn.me routing-mark=Route_5
add check-gateway=arp distance=4 gateway=freevpnaccess.com routing-mark=\
    Route_5
add check-gateway=arp distance=5 gateway=vpnbook.com routing-mark=Route_5

7) дописываем скрипт на сравнение старого пароля PPTP c новым из файликов для каждого интерфейса.

 

 

продолжение следует......

Изменено пользователем ruvhell
0

Поделиться этим ответом


Link to post
Share on other sites

в связи с выходом windows 10 и вкорячивания в windows 7 телеметрии, решил загубить это дело на роутере.

пытался написать скрипт по http://habrahabr.ru/post/242143/ , но т.к. адреса из листа http://habrahabr.ru/company/pt/blog/264763/ выдают не чистые записи типа А, у кучу CNAME у меня ничего не вышло....

 

пришлось воспользоваться топорным Layer7:

Создаем регулярное выражение в Layer 7

/ip firewall layer7-protocol add name=NoZond regexp="^.+(vortex.data.microsoft.com|vortex-win.data.microsoft.com|telecommand.telemetry.microsoft.com|telecommand.telemetry
.microsoft.com.nsatc.net|oca.telemetry.microsoft.com|oca.telemetry.microsoft.com
.
nsatc.net|sqm.telemetry.microsoft.com|sqm.telemetry.microsoft.com.nsatc.net|wats
o
n.telemetry.microsoft.com|watson.telemetry.microsoft.com.nsatc.net|redir.metaser
v
ices.microsoft.com|choice.microsoft.com|choice.microsoft.com.nsatc.net|df.teleme
t
ry.microsoft.com|reports.wes.df.telemetry.microsoft.com|wes.df.telemetry.microso
f
t.com|services.wes.df.telemetry.microsoft.com|sqm.df.telemetry.microsoft.com|tel
e
metry.microsoft.com|watson.ppe.telemetry.microsoft.com|telemetry.appex.bing.net|
t
elemetry.urs.microsoft.com|telemetry.appex.bing.net|settings-sandbox.data.microsoft.com|vortex-sandbox.data.microsoft.com|survey.watson.microsoft.com|watson.live.com|watson.mi
crosoft.com|statsfe2.ws.microsoft.com|corpext.msitadfs.glbdns2.microsoft.com|com
p
atexchange.cloudapp.net|cs1.wpc.v0cdn.net|a-0001.a-msedge.net|statsfe2.update.microsoft.com.akadns.net|diagnostics.support.microsof
t.com|corp.sts.microsoft.com|statsfe1.ws.microsoft.com|pre.footprintpredict.com|
i
1.services.social.microsoft.com|i1.services.social.microsoft.com.nsatc.net|feedb
a
ck.windows.com|feedback.microsoft-hohm.com|feedback.search.microsoft.com|rad.msn.com|preview.msn.com|ad.doubleclic
k.net|ads.msn.com|ads1.msads.net|ads1.msn.com|a.ads1.msn.com|a.ads2.msn.com|adne
x
us.net|adnxs.com|az361816.vo.msecnd.net|az512334.vo.msecnd.net).*$"

 

И добавляем его в правило Firewal, не забывая поместить выше разрешающих

ip firewall filter add chain=forward action=reject reject-with=tcp-reset protocol=tcp layer7-protocol=NoZond
ip firewall filter add chain=forward action=drop protocol=udp layer7-protocol=NoZond

 

тем самым мы загубили не только доступ на эти ресурсы, но даже и DNS запросы с этими именами

 

P/s windows update работает

 

P/P/S ну и, конечно, выключаем в windows

netsh int ipv6 set teredo disabled
netsh int ipv6 6to4 set state disabled
netsh int ipv6 isatap set state disabled

где

ISATAP - туннель ipv6 поверх IPv4. Необходим для связи двух островов IPv4 через сеть ipv6

teredo - туннель ipv6 поверх IPv4. Лезет напрямую через все NAT к серверу teredo.ipv6.microsoft.com (по умолчанию), получает там реальный ipv6.....

6to4 - туннель ipv6 поверх IPv4. Для его работы необходим белый IPv4 на интерфейсе. нужен для подключения к хостам на ipv6 с вашего IPv4

Изменено пользователем ruvhell
0

Поделиться этим ответом


Link to post
Share on other sites

 

Здравствуйте! Уже больше года прошло, после публикации, но поскольку тема с блокировками сайтов становиться, всё более актуальной, спрошу)

Не могли бы вы более разврнуто расписать пункты с 20го по 26й, из первого поста.

Спасибо!

0

Поделиться этим ответом


Link to post
Share on other sites

 

Здравствуйте! Уже больше года прошло, после публикации, но поскольку тема с блокировками сайтов становиться, всё более актуальной, спрошу)

Не могли бы вы более разврнуто расписать пункты с 20го по 26й, из первого поста.

Спасибо!

Добрый день!

 

а что конкретно не понятно?

кстати посмотрите 44 сообщение в этой ветке http://forum.onlime.ru/index.php?s=&sh...st&p=187480

0

Поделиться этим ответом


Link to post
Share on other sites

Подскажите а как поднять и настроить pptp клиент? Я чето не понял. Как ему пароли скормить разберусь.

add chain=forward comment=PPTP out-interface=pptp
add chain=output out-interface=pptp
add chain=forward in-interface=pptp
add chain=input in-interface=pptp

 

Еще у меня в правилах "заблокировать все остальное", вот в этих, в счетчиках попадает какой-то трафик. Как быть?

add action=drop chain=input comment="all other drop" 
add action=drop chain=forward comment="all other drop"

 

А что делать с приблудами для layer-7? Ну, добавил я как написано, а дальше что?

 

Спасибо.

0

Поделиться этим ответом


Link to post
Share on other sites
Подскажите а как поднять и настроить pptp клиент? Я чето не понял. Как ему пароли скормить разберусь.

/interface pptp-client
add connect-to=euro1.vpnmask.com disabled=no mrru=1600 name=freecloudvpn.com \
    password=adv7 user=vpnmask
add connect-to=176.126.237.207 disabled=no mrru=1600 name=freevpn.me \
    password="8uHbdwtJf\
    \n" user=pptp
add connect-to=83.170.84.216 disabled=no mrru=1600 name=freevpnaccess.com \
    password=1044 user=freevpnaccess.com
add connect-to=us1.vpnbook.com disabled=no mrru=1600 name=vpnbook.com \
    password=QABraz5q user=vpnbook
add connect-to=de1.vpnme.me disabled=no mrru=1600 name=vpnme.me password=\
    6gYcdX user=vpnme
add connect-to=uk2.worldvpn.net mrru=1600 name=worldvpn.net password=683379 \
    user=trial90187
add connect-to=ems11.your-freedom.de keepalive-timeout=disabled name=\
    your-freedom.net password=ZZZZZZZZZZZ user=XXXXXXXXXXXXX

можно через web интерфейс

 

разрешающее правило в firewall

/ip firewall filter
add chain=forward comment=PPTP out-interface=all-ppp
add chain=output out-interface=all-ppp
add chain=forward in-interface=all-ppp
add chain=input in-interface=all-ppp

NAT

/ip firewall nat
add action=masquerade chain=srcnat out-interface=vpnbook.com src-address=\
    VVV.VVV.VVV.0/24
# worldvpn.net not ready
add action=masquerade chain=srcnat out-interface=worldvpn.net src-address=\
    VVV.VVV.VVV.0/24
# freecloudvpn.com not ready
add action=masquerade chain=srcnat out-interface=freecloudvpn.com \
    src-address=VVV.VVV.VVV.0/24
add action=masquerade chain=srcnat out-interface=freevpn.me src-address=\
    VVV.VVV.VVV.0/24
# freevpnaccess.com not ready
add action=masquerade chain=srcnat out-interface=freevpnaccess.com \
    src-address=VVV.VVV.VVV.0/24
# vpnme.me not ready
add action=masquerade chain=srcnat out-interface=vpnme.me src-address=\
    VVV.VVV.VVV.0/24

 

Еще у меня в правилах "заблокировать все остальное", вот в этих, в счетчиках попадает какой-то трафик. Как быть?

правила отрабатываются по порядковым номерам по очереди!!!!! т.е. нужно ставить с начало разрешающие а в конце запрещающие! если на оборот - то до разрешающих не дойдет очередь - все будет запрещено.

 

А что делать с приблудами для layer-7? Ну, добавил я как написано, а дальше что?

Это вы про слежение в Windows? если да, то все что попало под какое-то правило в layer-7 нужно дропить и реджектить в firewall. Разгребать не для бана торенты и т.д слишком накладно по ресурсам железки - скорость падает

 

 

У меня там такая каша из настроек... я как разобрался с ними так и не трогаю - работает как часы. Тем более желание пропало, да и интересы сместились + на работе завал.

 

Т.к pptp постоянно меняют пароли - состояние, при котором часть из них отвалены - нормальное. Главное чтобы хотя бы 1 работал. Иначе все пойдет через провайдера и я увижу страницу-заглушку

 

Ps сообщение 33 http://forum.onlime.ru/index.php?s=&sh...st&p=172655 содержит правила для firewall

сообщение 44 http://forum.onlime.ru/index.php?s=&sh...st&p=187480 содержит mangle+route

сообщение 45 Layer 7+firewall

Изменено пользователем ruvhell
0

Поделиться этим ответом


Link to post
Share on other sites

Пока что добавил правило блокирующие dns-флуд. А то много входящих соединений на 53-й порт.

# drop dns flood

add action=drop chain=input in-interface=ether1-gateway protocol=udp port=53 comment="dns flood"

или вариант с блеклистом

# drop dns flood with blacklist

add action=drop chain=input in-interface=ether1-gateway comment="dns flood" port=53 protocol=udp src-address-list=dns_black_list
add action=add-src-to-address-list comment="dns flood" address-list=dns_black_list address-list-timeout=1d chain=input connection-state=new port=53 protocol=udp

0

Поделиться этим ответом


Link to post
Share on other sites

Скажие пожалуйтса, что дают правила "помойка из layer7 - почти не использую в дереве"

сообщение 33 http://forum.onlime.ru/index.php?s=&sh...st&p=172655 содержит правила для firewall

Я добавил, и чего с ними делать то? Я так понимаю нужны какие-то правила для файрвола, а правила есть только для NoZond. Или все кроме NoZond для маркинга траффика и можно удалить?

 

post-37205-1448745308_thumb.jpg

 

Самый главный вопрос, как получается база заблокированных сайтов? Ротутер же должен знать что речь идет о заблокированном ресурсе

Я так понимаю это russianbl

Как его сделать?

Изменено пользователем EOF
0

Поделиться этим ответом


Link to post
Share on other sites
Скажие пожалуйтса, что дают правила "помойка из layer7 - почти не использую в дереве"

 

Я добавил, и чего с ними делать то? Я так понимаю нужны какие-то правила для файрвола, а правила есть только для NoZond. Или все кроме NoZond для маркинга траффика и можно удалить?

после года использования - пришел к выводу, что приоритезация трафика снижает скорость скачивания торентов т.к. сильно грузит роутер. Соответсвенно, задизейблил в мангл все метки.

1 канал бесплатного pptp не стабилен, часто падает и слишком узок.

 

все правила layer7 можно стереть, кроме NoZond

 

а по поводу

Самый главный вопрос, как получается база заблокированных сайтов? Ротутер же должен знать что речь идет о заблокированном ресурсе

Я так понимаю это russianbl

я парсю https://github.com/zapret-info/z-i

22) на Linux машине

КОД допиливаем скрипт напильником ( я заменил на https://github.com/zapret-info/z-i т.к. он более актуальный), не забываем про chmod

 

я использовал bash, т.к всегда под рукой виртуалка с OEL....средствами винды(powershell) это так же сделать можно.... отпарсиный результат приводим к виду .csv

 

 

в пндлник, если сами не составите скрипт - я выложу все мои .sh тут

Изменено пользователем ruvhell
0

Поделиться этим ответом


Link to post
Share on other sites
в пндлник, если сами не составите скрипт - я выложу все мои .sh тут

Благодарю! С sh скриптами проблем нету, все парсится, на mikrotik заливаются vpn пароли и crapregistry.rsc

На этом сегодня закончил, надо проверять и теститровать дальше..

 

0

Поделиться этим ответом


Link to post
Share on other sites

У меня завелось все! Ресурс из блеклиста открывается через freevpnacces автоматически!

Правда есть еще вопросы и надо кое что допилить, думаю сам справлюсь если нет спрошу!

Спасибо ruvhell!!!

0

Поделиться этим ответом


Link to post
Share on other sites
все правила layer7 можно стереть, кроме NoZond

 

а по поводу

 

я парсю https://github.com/zapret-info/z-i

 

 

я использовал bash, т.к всегда под рукой виртуалка с OEL....средствами винды(powershell) это так же сделать можно.... отпарсиный результат приводим к виду .csv

 

 

в пндлник, если сами не составите скрипт - я выложу все мои .sh тут

 

Выложите пожалуйста свои скрипты

0

Поделиться этим ответом


Link to post
Share on other sites
Выложите пожалуйста свои скрипты

генерация списка запрещенных IP

раскрывая этот код, Вы берете на себя все риски и ответственность, одновременно освобождая автора от каких-либо претензий, требований, а так же от любой ответственности. Вы принимаете и соглашаетесь с тем, что код предоставляется "КАК ЕСТЬ" и распространяется по модели GNU General Public License
#!/bin/sh
#Simple script to convert list of ip addresses to
#Mikrotik import file (address list feature)
#Can also parse IPs from any text file (ie csv)
#SETTINGS
#url of input file
#url="http://api.antizapret.info/group.php"
url="https://raw.githubusercontent.com/zapret-info/z-i/master/dump.csv"
#address list in mikrotik
list="russianbl"
#Where to download source file
downfile="/tmp/templist.txt"
#File with cleaned & formatted ip addresses
infile="/tmp/craplist.txt"
#Where to put rsc script
outfile="/tmp/crapregistry.rsc"
wget $url -O $downfile --no-check-certificate
#This will extract all IPs from file (ie works with .csv russian blocklist)
#sed -n 's/\([0-9]\{1,3\}\.\)\{3\}[0-9]\{1,3\}/\nip&\n/gp' $downfile | grep ip | sed 's/ip//'| sort | uniq >> $infile
grep -E -o '(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)' $downfile | sort | uniq >> $infile

#We need to drop all IPs in address list because mikrotik does not check for duplicates (and they may be removed from file)
echo "#" >> $outfile
echo "#" >> $outfile
echo "#" >> $outfile

echo /ip firewall address-list remove [find list=$list] >> $outfile
#Build rsc file...
for line in $(cat $infile)
do
echo /ip firewall address-list add address="$line" list="$list" >> $outfile
done
#rm $downfile $infile

Изменено пользователем ruvhell
0

Поделиться этим ответом


Link to post
Share on other sites

Вот более актуальный скрипт для парсинга паролей. Пути поменять на свои. freecloudvpn.com у меня не открывается, по этому только 4-ре сервиса.

Хотел спросить по какой методе искать новые бесплатные vpn сервисы?

 

curl -s "https://www.vpnme.me/freevpn.html" | grep -A 3 "Password:" | head -n 2 | cut -f2 -s -d "<" | cut -f2 -d ">" | grep -v -e '^$' > /home/wwwuser/server.my/htdocs/pptp/vpnme.me.txt
curl -s "http://freevpnaccess.com" | grep -A 8 "UK - London" | tail -n 1 | cut -f1 -d " " | tr -cd [:digit:] | grep -v -e '^$' > /home/wwwuser/server.my/htdocs/pptp/freevpnaccess.com.txt
curl -s "http://freevpn.me/accounts/" | grep -A 3 "Password:" | head -n 1 | cut -f2 -d ":" | cut -f2 -d ">" | cut -b 3- | cut -f1 -d "<" | grep -v -e '^$' > /home/wwwuser/server.my/htdocs/pptp/freevpn.me.txt
curl -s "http://www.vpnbook.com/" | grep -A 1 "Username: vpnbook" | tail -n 1 | cut -f2 -d ":" | cut -b 2- | cut -f1 -d '<' | grep -v -e '^$' > /home/wwwuser/server.my/htdocs/pptp/vpnbook.com.txt

 

Скрипт заливки полученных паролей на роутер. Пути и пароли поменять на свои.

 

#!/bin/sh
LOCALDIR=/home/wwwuser/server.my/htdocs/pptp
REMOTESERVER=192.168.1.1
REMOTEPATH=/pptp
LOGIN=admin
PASSWORD=yourpassword

cd $LOCALDIR
ftp -n $REMOTESERVER <<INPUT_END
quote user $LOGIN
quote pass $PASSWORD
cd $REMOTEPATH
put vpnme.me.txt
put freevpnaccess.com.txt
put freevpn.me.txt
put vpnbook.com.txt
exit
INPUT_END

 

Если кому надо, могу выложить все скрипты и настройки... :rolleyes:

Изменено пользователем EOF
0

Поделиться этим ответом


Link to post
Share on other sites
Если кому надо, могу выложить все скрипты и настройки... :rolleyes:

Если не сложно)

Спасибо огромное!

Изменено пользователем pdmitry2
0

Поделиться этим ответом


Link to post
Share on other sites

включаем iptv через DLNA Media Server на mikrotik

нам в помощь:

http://www.k4route.ru/2014/06/iptv-mikrotik-dlna.html

http://habrahabr.ru/post/180889/

http://habrahabr.ru/post/248009/

http://xupnpd.org/

 

Прежде чем приступить

- выясним архитектуру процессора роутера- у меня MIPS

- определимся с виртуальным роутером - я выбрал OpenWRT

 

роутер в роутере? we need go deeper! :lol:

 

 

ставим виртуальный роутер (METArouter)

1) качаем под наш проц OpenWRT openwrt-mr-mips-rootfs и закидываем на наш роутер

2) в METArouter импортируем наш закаченный файлик и выставляем RAM не менее 64мб и hdd не менее 32мб

3) в METArouter - interfaces создаем новый ( по инструкции из начала сообщения)

4) открываем из этого окна консоль нового роутера и настраиваем:

-

passwd

задаем новый пароль для root

- через редактор vi задаем сетевые настройки

vi /etc/config/network

option ifname 'eth0'

option 'proto' 'static'

option 'ipaddr' 'ччч.ккк.еее.ннн'

option 'netmask' '255.255.255.0'

option 'dns' '8.8.8.8'

option 'gateway' 'ччч.ккк.еее.ммм'

 

сохраняем и закрываем

Esc -> :w -> ctrl+z

 

передергиваем

/etc/init.d/network enable
/etc/init.d/network restart

теперь пинги должны пойти.

 

прописываем валидный репозитарий

vi /etc/opkg.conf

src/gz snapshots http://openwrt.wk.cz/kamikaze/packages/mr-mips

dest root /

dest ram /tmp

lists_dir ext /var/opkg-lists

option overlay_root /overlay

 

сохраняем и закрываем

Esc -> :w -> ctrl+z

 

по идее web морда должна стоять. но если ее нету - то ставим

 

opkg update
opkg list
opkg install webif

 

5) Далее ставим пакеты

vsftpd - нужно для заливки xupnpd

без этих библиотек у меня xupnpd не запускался

libgcc

libgmp

libgpg-error

libiptc

liblua

libncurses

libpopt

libpthread

libstdcpp

libuci

libxtables

uclibc

uclibcxx

 

рестартим виртуалку

7) скачиваем на компе xupnpd-1_033-static.tar.gz и по ftp закачиваем на наш виртуальный роутер

8) перемещаемся в консоли в папку с xupnpd-1_033-static.tar.gz и

распаковываем

tar -xzf xupnpd-1_033-static.tar.gz

удаляем

rm xupnpd-1_033-static.tar.gz

 

перемещаемся в распакованную папку

cd xupnpd-rc

и запускаем (если в команде

ls -a

не подсвечен зеленым этот файлик, то chmod его)

./xupnpd-ar231x-bf

 

теперь в браузере можно открыть ip ччч.ккк.еее.ннн:4044

 

9) осталось только в автозапуск запихнуть запущенный файл по его пути (/папка/папка1/папка2/)

vi /etc/rc.local

# Put your custom commands here that should be executed once

# the system init finished. By default this file does nothing.

 

/папка/папка1/папка2/xupnpd-rc/xupnpd-ar231x-bf

exit 0

сохраняем и закрываем

Esc -> :w -> ctrl+z

 

настраиваем xupnpd

гуглим "free iptv playlist" или нечто подобное

 

скачиваем m3u файлики

или

в пустой текстовый файл вставляем найденные записи вида:

 

#EXTINF:0,Discovery Channel HD
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
http://slynet.8nio.com/at/discoveryhd_sly.m3u8

после сохраняем его под любым названием желательно без точек и пробелов с расширением m3u

 

через web морду xupnpd[ закачиваем его .....

 

мой лист iptv (что-то работает - что то нет)

 

почему то код не пашет

[expand]   [/expand]

 

первый попавшийся m3u
#EXTM3U
#EXTINF:0,=== LISTIPTV.RU ===
#EXTGRP:РОССИЙСКИЕ
[url="http://j.mp/1FwLpEb?.m3u8"]http://j.mp/1FwLpEb?.m3u8[/url]
#EXTINF:0,=== РОССИЙСКИЕ ===
#EXTGRP:РОССИЙСКИЕ
[url="http://j.mp/1FwLpEb?.m3u8"]http://j.mp/1FwLpEb?.m3u8[/url]
#EXTINF:0,Первый канал
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/at/perviykanal_sly.m3u8"]http://slynet.8nio.com/at/perviykanal_sly.m3u8[/url]
#EXTINF:0,Первый канал
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/im/perviykanal_sly.m3u8"]http://slynet.8nio.com/im/perviykanal_sly.m3u8[/url]
#EXTINF:0,Первый канал
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/v/perviykanal_sly.m3u8"]http://slynet.8nio.com/v/perviykanal_sly.m3u8[/url]
#EXTINF:0,Россия 1
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/im/russia1_sly.m3u8"]http://slynet.8nio.com/im/russia1_sly.m3u8[/url]
#EXTINF:0,Россия 1
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/p/russia1_sly.m3u8"]http://slynet.8nio.com/p/russia1_sly.m3u8[/url]
#EXTINF:0,Россия 1 
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/bs/russia1_sly.m3u8"]http://slynet.8nio.com/bs/russia1_sly.m3u8[/url]
#EXTINF:0,Россия 1 
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/v/russia1_sly.m3u8"]http://slynet.8nio.com/v/russia1_sly.m3u8[/url]
#EXTINF:0,Россия HD
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/bs/russiahd_sly.m3u8"]http://slynet.8nio.com/bs/russiahd_sly.m3u8[/url]
#EXTINF:0,Россия К
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/im/russiak_sly.m3u8"]http://slynet.8nio.com/im/russiak_sly.m3u8[/url]
#EXTINF:0,Россия К 
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/bs/russiak_sly.m3u8"]http://slynet.8nio.com/bs/russiak_sly.m3u8[/url]
#EXTINF:0,ТНТ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/im/tnt_sly.m3u8"]http://slynet.8nio.com/im/tnt_sly.m3u8[/url]
#EXTINF:0,ТНТ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/p/tnt_sly.m3u8"]http://slynet.8nio.com/p/tnt_sly.m3u8[/url]
#EXTINF:0,ТНТ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/at/tnt_sly.m3u8"]http://slynet.8nio.com/at/tnt_sly.m3u8[/url]
#EXTINF:0,НТВ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/im/ntv_sly.m3u8"]http://slynet.8nio.com/im/ntv_sly.m3u8[/url]
#EXTINF:0,НТВ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/p/ntv_sly.m3u8"]http://slynet.8nio.com/p/ntv_sly.m3u8[/url]
#EXTINF:0,НТВ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/v/ntv_sly.m3u8"]http://slynet.8nio.com/v/ntv_sly.m3u8[/url]
#EXTINF:0,НТВ 
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/bs/ntv_sly.m3u8"]http://slynet.8nio.com/bs/ntv_sly.m3u8[/url]
#EXTINF:0,СТС
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/im/sts_sly.m3u8"]http://slynet.8nio.com/im/sts_sly.m3u8[/url]
#EXTINF:0,СТС
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/v/sts_sly.m3u8"]http://slynet.8nio.com/v/sts_sly.m3u8[/url]
#EXTINF:0,СТС Love
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/kz/stslove_sly.m3u8"]http://slynet.8nio.com/kz/stslove_sly.m3u8[/url]
#EXTINF:0,СТС Мир
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/p/stsmir_sly.m3u8"]http://slynet.8nio.com/p/stsmir_sly.m3u8[/url]
#EXTINF:0,РЕН ТВ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/v/rentv_sly.m3u8"]http://slynet.8nio.com/v/rentv_sly.m3u8[/url]
#EXTINF:0,РЕН ТВ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/1/rentv_sly.m3u8"]http://slynet.8nio.com/1/rentv_sly.m3u8[/url]
#EXTINF:0,РЕН ТВ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/v/rentv2_sly.m3u8"]http://slynet.8nio.com/v/rentv2_sly.m3u8[/url]
#EXTINF:0,Рен ТВ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/p/rentv_sly.m3u8"]http://slynet.8nio.com/p/rentv_sly.m3u8[/url]
#EXTINF:0,РЕН ТВ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/im/rentv_sly.m3u8"]http://slynet.8nio.com/im/rentv_sly.m3u8[/url]
#EXTINF:0,Пятый Канал Россия
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/bs/5channel_sly.m3u8"]http://slynet.8nio.com/bs/5channel_sly.m3u8[/url]
#EXTINF:0,Пятый канал Россия
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/p/5kanal_sly.m3u8"]http://slynet.8nio.com/p/5kanal_sly.m3u8[/url]
#EXTINF:0,ТВЦ
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/at/tvc_sly.m3u8"]http://slynet.8nio.com/at/tvc_sly.m3u8[/url]
#EXTINF:0,Домашний
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/v/domashniy_sly.m3u8"]http://slynet.8nio.com/v/domashniy_sly.m3u8[/url]
#EXTINF:0,Домашний
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/p/domashniy_sly.m3u8"]http://slynet.8nio.com/p/domashniy_sly.m3u8[/url]
#EXTINF:0,Звезда
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/im/zvezda_sly.m3u8"]http://slynet.8nio.com/im/zvezda_sly.m3u8[/url]
#EXTINF:0,Звезда
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/mn/zvezda_sly.m3u8"]http://slynet.8nio.com/mn/zvezda_sly.m3u8[/url]
#EXTINF:0,Звезда
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/p/zvezda_sly.m3u8"]http://slynet.8nio.com/p/zvezda_sly.m3u8[/url]
#EXTINF:0,Звезда
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/v/zvezda_sly.m3u8"]http://slynet.8nio.com/v/zvezda_sly.m3u8[/url]
#EXTINF:0,Звезда 
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/bs/zvezda_sly.m3u8"]http://slynet.8nio.com/bs/zvezda_sly.m3u8[/url]
#EXTINF:0,ОТР
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/p/otvrus_sly.m3u8"]http://slynet.8nio.com/p/otvrus_sly.m3u8[/url]
#EXTINF:0,ОТР 
#EXTGRP:РОССИЙСКИЕ
[url="http://slynet.8nio.com/mn/otvrus_sly.m3u8"]http://slynet.8nio.com/mn/otvrus_sly.m3u8[/url]
#EXTINF:0,=== РЕГИОНАЛЬНЫЕ ===
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,Первый канал +4
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://slynet.8nio.com/mn/perviykanal_sly.m3u8"]http://slynet.8nio.com/mn/perviykanal_sly.m3u8[/url]
#EXTINF:0,Москва 24
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://slynet.8nio.com/1/moscow24_sly.m3u8"]http://slynet.8nio.com/1/moscow24_sly.m3u8[/url]
#EXTINF:0,ТВ3 +3
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://slynet.8nio.com/p/tv33_sly.m3u8"]http://slynet.8nio.com/p/tv33_sly.m3u8[/url]
#EXTINF:0,ТВ3 +4
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://slynet.8nio.com/mn/tv3_sly.m3u8"]http://slynet.8nio.com/mn/tv3_sly.m3u8[/url]
#EXTINF:0,ТНТ +3
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://slynet.8nio.com/p/tnt3_sly.m3u8"]http://slynet.8nio.com/p/tnt3_sly.m3u8[/url]
#EXTINF:0,ТНТ +4
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://slynet.8nio.com/mn/tnt_sly.m3u8"]http://slynet.8nio.com/mn/tnt_sly.m3u8[/url]
#EXTINF:0,Беларусь 1
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://slynet.8nio.com/1/belarus1_sly.m3u8"]http://slynet.8nio.com/1/belarus1_sly.m3u8[/url]
#EXTINF:0,Беларусь 24
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://slynet.8nio.com/1/belarus24_sly.m3u8"]http://slynet.8nio.com/1/belarus24_sly.m3u8[/url]
#EXTINF:0,Астрахань 24 HD
#EXTGRP:РЕГИОНАЛЬНЫЕ
[url="http://slynet.8nio.com/bs/astrakhan24_sly.m3u8"]http://slynet.8nio.com/bs/astrakhan24_sly.m3u8[/url]
#EXTINF:0,=== НОВОСТИ ===
#EXTGRP:НОВОСТИ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,РБК
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/1/rbc_sly.m3u8"]http://slynet.8nio.com/1/rbc_sly.m3u8[/url]
#EXTINF:0,Россия 24
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/im/russia24_sly.m3u8"]http://slynet.8nio.com/im/russia24_sly.m3u8[/url]
#EXTINF:0,Россия 24
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/v/russia24_sly.m3u8"]http://slynet.8nio.com/v/russia24_sly.m3u8[/url]
#EXTINF:0,Россия 24
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/p/russia24_sly.m3u8"]http://slynet.8nio.com/p/russia24_sly.m3u8[/url]
#EXTINF:0,Россия 24
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/1/russia24_sly.m3u8"]http://slynet.8nio.com/1/russia24_sly.m3u8[/url]
#EXTINF:0,Россия 24
#EXTGRP:НОВОСТИ 
[url="http://slynet.8nio.com/bs/russia24_sly.m3u8"]http://slynet.8nio.com/bs/russia24_sly.m3u8[/url]
#EXTINF:0,Россия 24
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/mn/russia24_sly.m3u8"]http://slynet.8nio.com/mn/russia24_sly.m3u8[/url]
#EXTINF:0,Мир 24 
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/1/mir24_sly.m3u8"]http://slynet.8nio.com/1/mir24_sly.m3u8[/url]
#EXTINF:0,Lifenews
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/p/lifenews_sly.m3u8"]http://slynet.8nio.com/p/lifenews_sly.m3u8[/url]
#EXTINF:0,Lifenews
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/1/lifenews_sly.m3u8"]http://slynet.8nio.com/1/lifenews_sly.m3u8[/url]
#EXTINF:0,LifeNews
#EXTGRP:НОВОСТИ 
[url="http://slynet.8nio.com/bs/lifenews_sly.m3u8"]http://slynet.8nio.com/bs/lifenews_sly.m3u8[/url]
#EXTINF:0,LifeNews (Резерв)
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/1/lifenews2_sly.m3u8"]http://slynet.8nio.com/1/lifenews2_sly.m3u8[/url]
#EXTINF:0,LifeNews 78
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/1/lifenews78_sly.m3u8"]http://slynet.8nio.com/1/lifenews78_sly.m3u8[/url]
#EXTINF:0,LifeNews 78 HD
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/1/lifenews78hd_sly.m3u8"]http://slynet.8nio.com/1/lifenews78hd_sly.m3u8[/url]
#EXTINF:0,LifeNews HD
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/1/lifenewshd_sly.m3u8"]http://slynet.8nio.com/1/lifenewshd_sly.m3u8[/url]
#EXTINF:0,RT
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/mn/russiatoday_sly.m3u8"]http://slynet.8nio.com/mn/russiatoday_sly.m3u8[/url]
#EXTINF:0,RT
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/p/russiatoday_sly.m3u8"]http://slynet.8nio.com/p/russiatoday_sly.m3u8[/url]
#EXTINF:0,RT HD
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/bs/rttvhd_sly.m3u8"]http://slynet.8nio.com/bs/rttvhd_sly.m3u8[/url]
#EXTINF:0,RT Док HD
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/bs/rtdochd_sly.m3u8"]http://slynet.8nio.com/bs/rtdochd_sly.m3u8[/url]
#EXTINF:0,Дождь
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/mn/dozhd_sly.m3u8"]http://slynet.8nio.com/mn/dozhd_sly.m3u8[/url]
#EXTINF:0,Дождь
#EXTGRP:НОВОСТИ
[url="http://slynet.8nio.com/p/dozhd_sly.m3u8"]http://slynet.8nio.com/p/dozhd_sly.m3u8[/url]
#EXTINF:0,=== СПОРТ ===
#EXTGRP:СПОРТ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,Eurosport 1 
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/at/eurosport1_sly.m3u8"]http://slynet.8nio.com/at/eurosport1_sly.m3u8[/url]
#EXTINF:0,EUROSPORT 1 HD
#EXTGRP:СПОРТ 
[url="http://slynet.8nio.com/at/eurosport1hd_sly.m3u8"]http://slynet.8nio.com/at/eurosport1hd_sly.m3u8[/url]
#EXTINF:0,Матч ТВ
#EXTGRP:СПОРТ 
[url="http://slynet.8nio.com/p/matchtv_sly.m3u8"]http://slynet.8nio.com/p/matchtv_sly.m3u8[/url]
#EXTINF:0,Матч ТВ
#EXTGRP:СПОРТ 
[url="http://slynet.8nio.com/bs/matchtv_sly.m3u8"]http://slynet.8nio.com/bs/matchtv_sly.m3u8[/url]
#EXTINF:0,Матч ТВ
#EXTGRP:СПОРТ 
[url="http://slynet.8nio.com/v/matchtv_sly.m3u8"]http://slynet.8nio.com/v/matchtv_sly.m3u8[/url]
#EXTINF:0,Матч ТВ
#EXTGRP:СПОРТ  
[url="http://slynet.8nio.com/1/matchtv_sly.m3u8"]http://slynet.8nio.com/1/matchtv_sly.m3u8[/url]
#EXTINF:0,Матч ТВ
#EXTGRP:СПОРТ 
[url="http://slynet.8nio.com/mn/matchtv_sly.m3u8"]http://slynet.8nio.com/mn/matchtv_sly.m3u8[/url]
#EXTINF:0,Авто плюс
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/mn/avtoplus_sly.m3u8"]http://slynet.8nio.com/mn/avtoplus_sly.m3u8[/url]
#EXTINF:0,КХЛ 
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/at/khl_sly.m3u8"]http://slynet.8nio.com/at/khl_sly.m3u8[/url]
#EXTINF:0,НТВ-ПЛЮС Спорт
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/at/ntvplussport_sly.m3u8"]http://slynet.8nio.com/at/ntvplussport_sly.m3u8[/url]
#EXTINF:0,НТВ-ПЛЮС Теннис
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/at/ntvplustennis_sly.m3u8"]http://slynet.8nio.com/at/ntvplustennis_sly.m3u8[/url]
#EXTINF:0,НТВ-ПЛЮС Футбол 1
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/at/ntvplusfootball1_sly.m3u8"]http://slynet.8nio.com/at/ntvplusfootball1_sly.m3u8[/url]
#EXTINF:0,НТВ-ПЛЮС Футбол 2 
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/at/ntvplusfootball2_sly.m3u8"]http://slynet.8nio.com/at/ntvplusfootball2_sly.m3u8[/url]
#EXTINF:0,НТВ-ПЛЮС Футбол 3 
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/at/ntvplusfootball3_sly.m3u8"]http://slynet.8nio.com/at/ntvplusfootball3_sly.m3u8[/url]
#EXTINF:0,НТВ-ПЛЮС Наш Футбол
#EXTGRP:СПОРТ 
[url="http://slynet.8nio.com/at/ntvplusnashfootball_sly.m3u8"]http://slynet.8nio.com/at/ntvplusnashfootball_sly.m3u8[/url]
#EXTINF:0,НТВ-ПЛЮС СПОРТ ПЛЮС 
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/at/ntvplussportplus_sly.m3u8"]http://slynet.8nio.com/at/ntvplussportplus_sly.m3u8[/url]
#EXTINF:0,Футбол 1 Украина
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/mx/footbal1ua_sly.m3u8"]http://slynet.8nio.com/mx/footbal1ua_sly.m3u8[/url]
#EXTINF:0,Спорт
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/mn/sport_sly.m3u8"]http://slynet.8nio.com/mn/sport_sly.m3u8[/url]
#EXTINF:0,Спорт 1
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/p/sport1_sly.m3u8"]http://slynet.8nio.com/p/sport1_sly.m3u8[/url]
#EXTINF:0,Спорт 1 HD
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/1/sport1hd_sly.m3u8"]http://slynet.8nio.com/1/sport1hd_sly.m3u8[/url]
#EXTINF:0,Боец
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/p/boets_sly.m3u8"]http://slynet.8nio.com/p/boets_sly.m3u8[/url]
#EXTINF:0,Бокс ТВ
#EXTGRP:СПОРТ
[url="http://slynet.8nio.com/p/bokstv_sly.m3u8"]http://slynet.8nio.com/p/bokstv_sly.m3u8[/url]
#EXTINF:0,=== ПОЗНАВАТЕЛЬНЫЕ ===
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,24 Техно 
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/24techno_sly.m3u8"]http://slynet.8nio.com/mn/24techno_sly.m3u8[/url]
#EXTINF:0,Охота и рыбалка
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/ohotairiba_sly.m3u8"]http://slynet.8nio.com/mn/ohotairiba_sly.m3u8[/url]
#EXTINF:0,Живи
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/zhivi_sly.m3u8"]http://slynet.8nio.com/mn/zhivi_sly.m3u8[/url]
#EXTINF:0,Живи
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/zhivi_sly.m3u8"]http://slynet.8nio.com/p/zhivi_sly.m3u8[/url]
#EXTINF:0,Теледом HD
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/teledomhd_sly.m3u8"]http://slynet.8nio.com/1/teledomhd_sly.m3u8[/url]
#EXTINF:0,Nat Geo Wild
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/natgeowild_sly.m3u8"]http://slynet.8nio.com/at/natgeowild_sly.m3u8[/url]
#EXTINF:0,Совершенно секретно
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/v/topsecret_sly.m3u8"]http://slynet.8nio.com/v/topsecret_sly.m3u8[/url]
#EXTINF:0,Совершенно секретно
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/topsecret_sly.m3u8"]http://slynet.8nio.com/at/topsecret_sly.m3u8[/url] 
#EXTINF:0,Мужской
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/muzhskoy_sly.m3u8"]http://slynet.8nio.com/at/muzhskoy_sly.m3u8[/url]
#EXTINF:0,Мужской
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/muzhskoy_sly.m3u8"]http://slynet.8nio.com/p/muzhskoy_sly.m3u8[/url]
#EXTINF:0,Загородная жизнь
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/zagorodzh_sly.m3u8"]http://slynet.8nio.com/p/zagorodzh_sly.m3u8[/url]
#EXTINF:0,Наука 2.0
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mx/science20_sly.m3u8"]http://slynet.8nio.com/mx/science20_sly.m3u8[/url]
#EXTINF:0,History
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/history_sly.m3u8"]http://slynet.8nio.com/at/history_sly.m3u8[/url]
#EXTINF:0,Animal Planet
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/animalplanet_sly.m3u8"]http://slynet.8nio.com/at/animalplanet_sly.m3u8[/url]
#EXTINF:0,Discovery Channel
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/discovery_sly.m3u8"]http://slynet.8nio.com/at/discovery_sly.m3u8[/url]
#EXTINF:0,Discovery Channel HD
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/discoveryhd_sly.m3u8"]http://slynet.8nio.com/at/discoveryhd_sly.m3u8[/url]
#EXTINF:0,Discovery Investigation Xtra
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/iddiscovery_sly.m3u8"]http://slynet.8nio.com/at/iddiscovery_sly.m3u8[/url]
#EXTINF:0,Усадьба
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/usadba_sly.m3u8"]http://slynet.8nio.com/mn/usadba_sly.m3u8[/url]
#EXTINF:0,Amazing Life
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/amazinglife_sly.m3u8"]http://slynet.8nio.com/mn/amazinglife_sly.m3u8[/url]
#EXTINF:0,Animal Planet
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/animalplanet_sly.m3u8"]http://slynet.8nio.com/at/animalplanet_sly.m3u8[/url]
#EXTINF:0,Nat Geo Wild
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/natgeowild_sly.m3u8"]http://slynet.8nio.com/at/natgeowild_sly.m3u8[/url]
#EXTINF:0,Discovery Science 
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/discoveryscience_sly.m3u8"]http://slynet.8nio.com/at/discoveryscience_sly.m3u8[/url]
#EXTINF:0,История
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/istoriya_sly.m3u8"]http://slynet.8nio.com/at/istoriya_sly.m3u8[/url]
#EXTINF:0,Travel Channel 
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/travelchannel_sly.m3u8"]http://slynet.8nio.com/at/travelchannel_sly.m3u8[/url]
#EXTINF:0,Кухня ТВ
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/kuxnyatv_sly.m3u8"]http://slynet.8nio.com/at/kuxnyatv_sly.m3u8[/url]
#EXTINF:0,Телекафе
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/telecafe_sly.m3u8"]http://slynet.8nio.com/mn/telecafe_sly.m3u8[/url]
#EXTINF:0,National Geographic
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ 
[url="http://slynet.8nio.com/at/natgeo_sly.m3u8"]http://slynet.8nio.com/at/natgeo_sly.m3u8[/url]
#EXTINF:0,Zooпарк
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/bs/zoopark_sly.m3u8"]http://slynet.8nio.com/bs/zoopark_sly.m3u8[/url]
#EXTINF:0,Zooпарк 2
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/zoopark_sly.m3u8"]http://slynet.8nio.com/p/zoopark_sly.m3u8[/url]
#EXTINF:0,Калейдоскоп ТВ
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/v/kaledoskop_sly.m3u8"]http://slynet.8nio.com/v/kaledoskop_sly.m3u8[/url]
#EXTINF:0,Баланс ТВ
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/v/balans_sly.m3u8"]http://slynet.8nio.com/v/balans_sly.m3u8[/url]
#EXTINF:0,Первый МЕТЕО
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/1meteo_sly.m3u8"]http://slynet.8nio.com/at/1meteo_sly.m3u8[/url]
#EXTINF:0,Hope TV
#EXTGRP:ПОЗНАВАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/hopetv_sly.m3u8"]http://slynet.8nio.com/p/hopetv_sly.m3u8[/url]
#EXTINF:0,=== РАЗВЛЕКАТЕЛЬНЫЕ ===
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,Пятница
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/im/piatnica_sly.m3u8"]http://slynet.8nio.com/im/piatnica_sly.m3u8[/url]
#EXTINF:0,Пятница
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/piatnica_sly.m3u8"]http://slynet.8nio.com/mn/piatnica_sly.m3u8[/url]
#EXTINF:0,Пятница
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/piatnica_sly.m3u8"]http://slynet.8nio.com/p/piatnica_sly.m3u8[/url]
#EXTINF:0,Пятница
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/v/piatnica_sly.m3u8"]http://slynet.8nio.com/v/piatnica_sly.m3u8[/url]
#EXTINF:0,CBS Reality
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/2/cbsreality_sly.m3u8"]http://slynet.8nio.com/2/cbsreality_sly.m3u8[/url]
#EXTINF:0,Ю
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/im/u_sly.m3u8"]http://slynet.8nio.com/im/u_sly.m3u8[/url]
#EXTINF:0,Ю
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/u_sly.m3u8"]http://slynet.8nio.com/p/u_sly.m3u8[/url]
#EXTINF:0,Ю
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/v/u_sly.m3u8"]http://slynet.8nio.com/v/u_sly.m3u8[/url]
#EXTINF:0,Мужское кино
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/at/muzhskoekino_sly.m3u8"]http://slynet.8nio.com/at/muzhskoekino_sly.m3u8[/url]
#EXTINF:0,Для Двоих 
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/dlyadvoih_sly.m3u8"]http://slynet.8nio.com/1/dlyadvoih_sly.m3u8[/url]
#EXTINF:0,Для Двоих HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/dlyadvoihhd_sly.m3u8"]http://slynet.8nio.com/1/dlyadvoihhd_sly.m3u8[/url]
#EXTINF:0,WBC
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/kz/wbc_sly.m3u8"]http://slynet.8nio.com/kz/wbc_sly.m3u8[/url]
#EXTINF:0,Сарафан
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/sarafan_sly.m3u8"]http://slynet.8nio.com/mn/sarafan_sly.m3u8[/url]
#EXTINF:0,ТНТ Comedy 
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/tntcomedy_sly.m3u8"]http://slynet.8nio.com/mn/tntcomedy_sly.m3u8[/url]
#EXTINF:0,Luxury World
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/luxuryworld_sly.m3u8"]http://slynet.8nio.com/1/luxuryworld_sly.m3u8[/url]
#EXTINF:0,Ocean TV
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/oceantv_sly.m3u8"]http://slynet.8nio.com/mn/oceantv_sly.m3u8[/url]
#EXTINF:0,Юмор Box
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/yumor_sly.m3u8"]http://slynet.8nio.com/mn/yumor_sly.m3u8[/url]
#EXTINF:0,Юмор Box
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/yumor_sly.m3u8"]http://slynet.8nio.com/p/yumor_sly.m3u8[/url]
#EXTINF:0,World Fashion Europe HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/bs/wfhdeuhd_sly.m3u8"]http://slynet.8nio.com/bs/wfhdeuhd_sly.m3u8[/url]
#EXTINF:0,World Fashion Россия HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/bs/wfhd_sly.m3u8"]http://slynet.8nio.com/bs/wfhd_sly.m3u8[/url]
#EXTINF:0,Fashion TV
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/fashion_sly.m3u8"]http://slynet.8nio.com/mn/fashion_sly.m3u8[/url]
#EXTINF:0,Fashion TV
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/fashion_sly.m3u8"]http://slynet.8nio.com/p/fashion_sly.m3u8[/url]
#EXTINF:0,Djind DJS HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/djinddjshd_sly.m3u8"]http://slynet.8nio.com/1/djinddjshd_sly.m3u8[/url]
#EXTINF:0,Djing Animation HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/djinganimationhd_sly.m3u8"]http://slynet.8nio.com/1/djinganimationhd_sly.m3u8[/url]
#EXTINF:0,Djing Classic HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/djingclassichd_sly.m3u8"]http://slynet.8nio.com/1/djingclassichd_sly.m3u8[/url]
#EXTINF:0,Djing HOT HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/djinghothd_sly.m3u8"]http://slynet.8nio.com/1/djinghothd_sly.m3u8[/url]
#EXTINF:0,Djing Ibiza HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/djingibizahd_sly.m3u8"]http://slynet.8nio.com/1/djingibizahd_sly.m3u8[/url]
#EXTINF:0,Djing Underground HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/djingundergroundhd_sly.m3u8"]http://slynet.8nio.com/1/djingundergroundhd_sly.m3u8[/url]
#EXTINF:0,Jasmin TV
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/jasminchannel_sly.m3u8"]http://slynet.8nio.com/1/jasminchannel_sly.m3u8[/url]
#EXTINF:0,Jasmin TV HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/jasminchannelhd_sly.m3u8"]http://slynet.8nio.com/1/jasminchannelhd_sly.m3u8[/url]
#EXTINF:0,Eska Best TV HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/eskabesttvhd_sly.m3u8"]http://slynet.8nio.com/1/eskabesttvhd_sly.m3u8[/url]
#EXTINF:0,Eska Party TV HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/eskapartytvhd_sly.m3u8"]http://slynet.8nio.com/1/eskapartytvhd_sly.m3u8[/url]
#EXTINF:0,Eska Rock TV HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/eskarocktvhd_sly.m3u8"]http://slynet.8nio.com/1/eskarocktvhd_sly.m3u8[/url]
#EXTINF:0,Парк развлечений
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/parkrazvl_sly.m3u8"]http://slynet.8nio.com/p/parkrazvl_sly.m3u8[/url]
#EXTINF:0,Парк развлечений
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/mn/parkrazvl_sly.m3u8"]http://slynet.8nio.com/mn/parkrazvl_sly.m3u8[/url]
#EXTINF:0,Public TV HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/bs/publictvhd_sly.m3u8"]http://slynet.8nio.com/bs/publictvhd_sly.m3u8[/url]
#EXTINF:0,POLO Party HD
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
rtmp://stream.smcloud.net/live2/polo_party/polo_party_720p
#EXTINF:0,Новое Телевидение
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/1/novoetv_sly.m3u8"]http://slynet.8nio.com/1/novoetv_sly.m3u8[/url]
#EXTINF:0,ОТС
#EXTGRP:РАЗВЛЕКАТЕЛЬНЫЕ
[url="http://slynet.8nio.com/p/ots_sly.m3u8"]http://slynet.8nio.com/p/ots_sly.m3u8[/url]
#EXTINF:0,=== КИНО ===
#EXTGRP:КИНО
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,ТВ3
#EXTGRP:КИНО
[url="http://slynet.8nio.com/im/tv3_sly.m3u8"]http://slynet.8nio.com/im/tv3_sly.m3u8[/url]
#EXTINF:0,ТВ3
#EXTGRP:КИНО
[url="http://slynet.8nio.com/v/tv3_sly.m3u8"]http://slynet.8nio.com/v/tv3_sly.m3u8[/url]
#EXTINF:0,ТВ3
#EXTGRP:КИНО
[url="http://slynet.8nio.com/p/tv3_sly.m3u8"]http://slynet.8nio.com/p/tv3_sly.m3u8[/url]
#EXTINF:0,FilmBox
#EXTGRP:КИНО
[url="http://slynet.8nio.com/re/filmbox_sly.m3u8"]http://slynet.8nio.com/re/filmbox_sly.m3u8[/url]
#EXTINF:0,FilmBox ArtHouse
#EXTGRP:КИНО
[url="http://slynet.8nio.com/re/filmboxarthouse_sly.m3u8"]http://slynet.8nio.com/re/filmboxarthouse_sly.m3u8[/url]
#EXTINF:0,Еврокино
#EXTGRP:КИНО
[url="http://slynet.8nio.com/p/eurokino_sly.m3u8"]http://slynet.8nio.com/p/eurokino_sly.m3u8[/url]
#EXTINF:0,Fox
#EXTGRP:КИНО
[url="http://slynet.8nio.com/at/fox_sly.m3u8"]http://slynet.8nio.com/at/fox_sly.m3u8[/url]
#EXTINF:0,Fox Life
#EXTGRP:КИНО
[url="http://slynet.8nio.com/at/foxlife_sly.m3u8"]http://slynet.8nio.com/at/foxlife_sly.m3u8[/url]
#EXTINF:0,Amedia 1
#EXTGRP:КИНО
[url="http://slynet.8nio.com/p/amedia1_sly.m3u8"]http://slynet.8nio.com/p/amedia1_sly.m3u8[/url]
#EXTINF:0,AMEDIA 2
#EXTGRP:КИНО
[url="http://slynet.8nio.com/at/amedia2_sly.m3u8"]http://slynet.8nio.com/at/amedia2_sly.m3u8[/url]
#EXTINF:0,Дом кино
#EXTGRP:КИНО
[url="http://slynet.8nio.com/mn/domkino_sly.m3u8"]http://slynet.8nio.com/mn/domkino_sly.m3u8[/url]
#EXTINF:0,Русский Иллюзион 
#EXTGRP:КИНО
[url="http://slynet.8nio.com/bs/illuzionrus_sly.m3u8"]http://slynet.8nio.com/bs/illuzionrus_sly.m3u8[/url]
#EXTINF:0,Русский Роман
#EXTGRP:КИНО
[url="http://slynet.8nio.com/p/russianroman_sly.m3u8"]http://slynet.8nio.com/p/russianroman_sly.m3u8[/url]
#EXTINF:0,Русский Бестселлер
#EXTGRP:КИНО
[url="http://slynet.8nio.com/mn/russianbestseller_sly.m3u8"]http://slynet.8nio.com/mn/russianbestseller_sly.m3u8[/url]
#EXTINF:0,Русский экстрим
#EXTGRP:КИНО
[url="http://slynet.8nio.com/bs/russkiyextrim_sly.m3u8"]http://slynet.8nio.com/bs/russkiyextrim_sly.m3u8[/url]
#EXTINF:0,TLC 
#EXTGRP:КИНО 
[url="http://slynet.8nio.com/mn/tlc_sly.m3u8"]http://slynet.8nio.com/mn/tlc_sly.m3u8[/url]
#EXTINF:0,TV 1000
#EXTGRP:КИНО 
[url="http://slynet.8nio.com/mx/tv1000_sly.m3u8"]http://slynet.8nio.com/mx/tv1000_sly.m3u8[/url]
#EXTINF:0,TV 1000 Action
#EXTGRP:КИНО 
[url="http://slynet.8nio.com/mx/tv1000action_sly.m3u8"]http://slynet.8nio.com/mx/tv1000action_sly.m3u8[/url]
#EXTINF:0,TV 1000 Comedy HD
#EXTGRP:КИНО  
[url="http://slynet.8nio.com/re/tv1000comedyhd_sly.m3u8"]http://slynet.8nio.com/re/tv1000comedyhd_sly.m3u8[/url]
#EXTINF:0,TV 1000 Premium HD
#EXTGRP:КИНО 
[url="http://slynet.8nio.com/re/tv1000premiumhd_sly.m3u8"]http://slynet.8nio.com/re/tv1000premiumhd_sly.m3u8[/url]
#EXTINF:0,TV 1000 Megahit HD
#EXTGRP:КИНО 
[url="http://slynet.8nio.com/re/tv1000megahithd_sly.m3u8"]http://slynet.8nio.com/re/tv1000megahithd_sly.m3u8[/url]
#EXTINF:0,Cartoon Network
#EXTGRP:КИНО 
[url="http://slynet.8nio.com/at/cartoonnetwork_sly.m3u8"]http://slynet.8nio.com/at/cartoonnetwork_sly.m3u8[/url]
#EXTINF:0,Cartoon Network
#EXTGRP:КИНО 
[url="http://slynet.8nio.com/p/cartoonnetwork_sly.m3u8"]http://slynet.8nio.com/p/cartoonnetwork_sly.m3u8[/url]
#EXTINF:0,Комедия
#EXTGRP:КИНО 
[url="http://slynet.8nio.com/at/comediyatv_sly.m3u8"]http://slynet.8nio.com/at/comediyatv_sly.m3u8[/url]
#EXTINF:0,Индия ТВ 
#EXTGRP:КИНО
[url="http://slynet.8nio.com/at/india_sly.m3u8"]http://slynet.8nio.com/at/india_sly.m3u8[/url]
#EXTINF:0,НСТ
#EXTGRP:КИНО
[url="http://slynet.8nio.com/p/nst_sly.m3u8"]http://slynet.8nio.com/p/nst_sly.m3u8[/url]
#EXTINF:0,Public TV HD
#EXTGRP:КИНО
[url="http://slynet.8nio.com/bs/publictvhd_sly.m3u8"]http://slynet.8nio.com/bs/publictvhd_sly.m3u8[/url]
#EXTINF:0,=== ДЕТСКИЕ ===
#EXTGRP:ДЕТСКИЕ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,JimJam
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/va/jimjam_sly.m3u8"]http://slynet.8nio.com/va/jimjam_sly.m3u8[/url]
#EXTINF:0,2x2
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/im/2x2_sly.m3u8"]http://slynet.8nio.com/im/2x2_sly.m3u8[/url]
#EXTINF:0,2x2
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/p/2x2_sly.m3u8"]http://slynet.8nio.com/p/2x2_sly.m3u8[/url]
#EXTINF:0,2x2
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/v/2x2_sly.m3u8"]http://slynet.8nio.com/v/2x2_sly.m3u8[/url]
#EXTINF:0,2x2 +2
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/mn/2x2_sly.m3u8"]http://slynet.8nio.com/mn/2x2_sly.m3u8[/url]
#EXTINF:0,Nickelodeon
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/p/nickelodeon_sly.m3u8"]http://slynet.8nio.com/p/nickelodeon_sly.m3u8[/url]
#EXTINF:0,Nickelodeon
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/at/nickelodeon_sly.m3u8"]http://slynet.8nio.com/at/nickelodeon_sly.m3u8[/url]
#EXTINF:0,Boomerang
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/va/boomerang_sly.m3u8"]http://slynet.8nio.com/va/boomerang_sly.m3u8[/url]
#EXTINF:0,Nick Jr.
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/mx/nickjr_sly.m3u8"]http://slynet.8nio.com/mx/nickjr_sly.m3u8[/url]
#EXTINF:0,Карусель
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/p/karusel_sly.m3u8"]http://slynet.8nio.com/p/karusel_sly.m3u8[/url]
#EXTINF:0,Карусель
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/mn/karusel_sly.m3u8"]http://slynet.8nio.com/mn/karusel_sly.m3u8[/url]
#EXTINF:0,Карусель
#EXTGRP:ДЕТСКИЕ 
[url="http://slynet.8nio.com/bs/carousel_sly.m3u8"]http://slynet.8nio.com/bs/carousel_sly.m3u8[/url]
#EXTINF:0,Детский
#EXTGRP:ДЕТСКИЕ 
[url="http://slynet.8nio.com/p/detsky_sly.m3u8"]http://slynet.8nio.com/p/detsky_sly.m3u8[/url]
#EXTINF:0,Детский
#EXTGRP:ДЕТСКИЕ  
[url="http://slynet.8nio.com/bs/detsky_sly.m3u8"]http://slynet.8nio.com/bs/detsky_sly.m3u8[/url]
#EXTINF:0,Gulli
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/bs/gulli_sly.m3u8"]http://slynet.8nio.com/bs/gulli_sly.m3u8[/url]
#EXTINF:0,Мульт
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/kz/mult_sly.m3u8"]http://slynet.8nio.com/kz/mult_sly.m3u8[/url]
#EXTINF:0,Мама
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/p/mama_sly.m3u8"]http://slynet.8nio.com/p/mama_sly.m3u8[/url]
#EXTINF:0,Мама
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/mn/mama_sly.m3u8"]http://slynet.8nio.com/mn/mama_sly.m3u8[/url]
#EXTINF:0,ANI
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/kz/ani_sly.m3u8"]http://slynet.8nio.com/kz/ani_sly.m3u8[/url]
#EXTINF:0,Дисней
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/at/disney_sly.m3u8"]http://slynet.8nio.com/at/disney_sly.m3u8[/url]
#EXTINF:0,Дисней +2
#EXTGRP:ДЕТСКИЕ
[url="http://slynet.8nio.com/kz/disney_sly.m3u8"]http://slynet.8nio.com/kz/disney_sly.m3u8[/url]
#EXTINF:0,=== МУЗЫКА ===
#EXTGRP:МУЗЫКА
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,МУЗ ТВ
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/im/muztv_sly.m3u8"]http://slynet.8nio.com/im/muztv_sly.m3u8[/url]
#EXTINF:0,Девятая волна
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/bs/9volna_sly.m3u8"]http://slynet.8nio.com/bs/9volna_sly.m3u8[/url]
#EXTINF:0,Dange TV
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/im/dangetv_sly.m3u8"]http://slynet.8nio.com/im/dangetv_sly.m3u8[/url]
#EXTINF:0,Муз ТВ
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/mn/muztv_sly.m3u8"]http://slynet.8nio.com/mn/muztv_sly.m3u8[/url]
#EXTINF:0,Ля-минор
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/at/laminor_sly.m3u"]http://slynet.8nio.com/at/laminor_sly.m3u[/url]
#EXTINF:0,Европа Плюс
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/at/evropaplustv_sly.m3u8"]http://slynet.8nio.com/at/evropaplustv_sly.m3u8[/url]
#EXTINF:0,Шансон ТВ
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/shansontv_sly.m3u8"]http://slynet.8nio.com/1/shansontv_sly.m3u8[/url]
#EXTINF:0,A-ONE
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/p/aone_sly.m3u8"]http://slynet.8nio.com/p/aone_sly.m3u8[/url]
#EXTINF:0,1HD
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/p/firstmuz_sly.m3u8"]http://slynet.8nio.com/p/firstmuz_sly.m3u8[/url]
#EXTINF:0,Music box
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/mn/musboxtv_sly.m3u8"]http://slynet.8nio.com/mn/musboxtv_sly.m3u8[/url]
#EXTINF:0,Music box
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/p/musboxtv_sly.m3u8"]http://slynet.8nio.com/p/musboxtv_sly.m3u8[/url]
#EXTINF:0,JuCeTV HD
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/jucetvhd_sly.m3u8"]http://slynet.8nio.com/1/jucetvhd_sly.m3u8[/url]
#EXTINF:0,MTV
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/at/mtv_sly.m3u8"]http://slynet.8nio.com/at/mtv_sly.m3u8[/url]
#EXTINF:0,MTV Dance
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/at/mtvdance_sly.m3u8"]http://slynet.8nio.com/at/mtvdance_sly.m3u8[/url]
#EXTINF:0,MTV AM HD
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/mtvamhd_sly.m3u8"]http://slynet.8nio.com/1/mtvamhd_sly.m3u8[/url]
#EXTINF:0,RU.TV
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/mn/rutv_sly.m3u8"]http://slynet.8nio.com/mn/rutv_sly.m3u8[/url]
#EXTINF:0,RUSONG TV 
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/mn/rusong_sly.m3u8"]http://slynet.8nio.com/mn/rusong_sly.m3u8[/url]
#EXTINF:0,Russian Music box
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/mn/musboxru_sly.m3u8"]http://slynet.8nio.com/mn/musboxru_sly.m3u8[/url]
#EXTINF:0,Russian Music box
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/p/musboxru_sly.m3u8"]http://slynet.8nio.com/p/musboxru_sly.m3u8[/url]
#EXTINF:0,RETRO TV
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/retrotv_sly.m3u8"]http://slynet.8nio.com/1/retrotv_sly.m3u8[/url]
#EXTINF:0,VH1 European
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/at/vh1european_sly.m3u8"]http://slynet.8nio.com/at/vh1european_sly.m3u8[/url]
#EXTINF:0,One HD
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/onehd_sly.m3u8"]http://slynet.8nio.com/1/onehd_sly.m3u8[/url]
#EXTINF:0,One UHD
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/oneuhd_sly.m3u8"]http://slynet.8nio.com/1/oneuhd_sly.m3u8[/url]
#EXTINF:0,OneRUS HD
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/onerushd_sly.m3u8"]http://slynet.8nio.com/1/onerushd_sly.m3u8[/url]
#EXTINF:0,VEVO 1
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/vevo1_sly.m3u8"]http://slynet.8nio.com/1/vevo1_sly.m3u8[/url]
#EXTINF:0,VEVO 2
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/vevo2_sly.m3u8"]http://slynet.8nio.com/1/vevo2_sly.m3u8[/url]
#EXTINF:0,VEVO 3
#EXTGRP:МУЗЫКА
[url="http://slynet.8nio.com/1/vevo3_sly.m3u8"]http://slynet.8nio.com/1/vevo3_sly.m3u8[/url]
#EXTINF:0,Kiss TV
#EXTGRP:МУЗЫКА
[url="http://186.2.168.109/musicch2?.m3u8"]http://186.2.168.109/musicch2?.m3u8[/url]
#EXTINF:0,Ретро TV
#EXTGRP:МУЗЫКА
[url="http://186.2.168.109/retrocz?.m3u8"]http://186.2.168.109/retrocz?.m3u8[/url]
#EXTINF:0,Hardlife
#EXTGRP:МУЗЫКА
rtmp://stream.hardlife.tv/live/hl
#EXTINF:0,HD Jazz
#EXTGRP:МУЗЫКА
rtmp://91.201.78.3:1935/live/jazzhd
#EXTINF:0,=== ДРУГИЕ ===
#EXTGRP:ДРУГИЕ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,Brodilo HD
#EXTGRP:ДРУГИЕ
[url="http://slynet.8nio.com/1/brodilohd_sly.m3u8"]http://slynet.8nio.com/1/brodilohd_sly.m3u8[/url]
#EXTINF:0,=== УКРАИНА ===
#EXTGRP:УКРАИНА
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,Интер 
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/inter_sly.m3u8"]http://slynet.8nio.com/mx/inter_sly.m3u8[/url]
#EXTINF:0,112
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/112_sly.m3u8"]http://slynet.8nio.com/lt/112_sly.m3u8[/url]
#EXTINF:0,112 UA HD
#EXTGRP:УКРАИНА 
[url="http://slynet.8nio.com/1/112hd_sly.m3u8"]http://slynet.8nio.com/1/112hd_sly.m3u8[/url]
#EXTINF:0,News One 
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/newsone_sly.m3u8"]http://slynet.8nio.com/mx/newsone_sly.m3u8[/url]
#EXTINF:0,1+1
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/1plus1_sly.m3u8"]http://slynet.8nio.com/lt/1plus1_sly.m3u8[/url]
#EXTINF:0,5 канал Украина
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/5kanalua_sly.m3u8"]http://slynet.8nio.com/lt/5kanalua_sly.m3u8[/url]
#EXTINF:0,ICTV
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/ictv_sly.m3u8"]http://slynet.8nio.com/mx/ictv_sly.m3u8[/url]
#EXTINF:0,ZIK
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/zik_sly.m3u8"]http://slynet.8nio.com/lt/zik_sly.m3u8[/url]
#EXTINF:0,Бигуди
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/bigudi_sly.m3u8"]http://slynet.8nio.com/lt/bigudi_sly.m3u8[/url]
#EXTINF:0,Гамма
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/heltv_sly.m3u8"]http://slynet.8nio.com/lt/heltv_sly.m3u8[/url]
#EXTINF:0,Громадське-TB
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/hromadsketv_sly.m3u8"]http://slynet.8nio.com/lt/hromadsketv_sly.m3u8[/url]
#EXTINF:0,Еспресо TV HD
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/espresotvhd_sly.m3u8"]http://slynet.8nio.com/lt/espresotvhd_sly.m3u8[/url]
#EXTINF:0,Еспресо TV
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/espresotv_sly.m3u8"]http://slynet.8nio.com/lt/espresotv_sly.m3u8[/url]
#EXTINF:0,Ентер Фильм
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/enterfilm_sly.m3u8"]http://slynet.8nio.com/mx/enterfilm_sly.m3u8[/url]
#EXTINF:0,K1
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/k1_sly.m3u8"]http://slynet.8nio.com/mx/k1_sly.m3u8[/url]
#EXTINF:0,К2
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/k2_sly.m3u8"]http://slynet.8nio.com/mx/k2_sly.m3u8[/url]
#EXTINF:0,Культура UA
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/cultureua_sly.m3u8"]http://slynet.8nio.com/mx/cultureua_sly.m3u8[/url]
#EXTINF:0,Мега
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/mega_sly.m3u8"]http://slynet.8nio.com/mx/mega_sly.m3u8[/url]
#EXTINF:0,НТН 
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/ntn_sly.m3u8"]http://slynet.8nio.com/mx/ntn_sly.m3u8[/url]
#EXTINF:0,Новый Канал 
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/newkanal_sly.m3u8"]http://slynet.8nio.com/mx/newkanal_sly.m3u8[/url]
#EXTINF:0,Плюс Плюс
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/plusplus_sly.m3u8"]http://slynet.8nio.com/lt/plusplus_sly.m3u8[/url]
#EXTINF:0,СТБ
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/mx/stb_sly.m3u8"]http://slynet.8nio.com/mx/stb_sly.m3u8[/url]
#EXTINF:0,ТЕТ
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/tet_sly.m3u8"]http://slynet.8nio.com/lt/tet_sly.m3u8[/url]
#EXTINF:0,3S.TV
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/3stv_sly.m3u8"]http://slynet.8nio.com/lt/3stv_sly.m3u8[/url]
#EXTINF:0,RTI HD
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/1/rtihd_sly.m3u8"]http://slynet.8nio.com/1/rtihd_sly.m3u8[/url]
#EXTINF:0,Рада
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/lt/rada_sly.m3u8"]http://slynet.8nio.com/lt/rada_sly.m3u8[/url]
#EXTINF:0,ПИК ТВ
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/1/piktv_sly.m3u8"]http://slynet.8nio.com/1/piktv_sly.m3u8[/url]
#EXTINF:0,ПИК ТВ HD
#EXTGRP:УКРАИНА
[url="http://slynet.8nio.com/p/piktvhd_sly.m3u8"]http://slynet.8nio.com/p/piktvhd_sly.m3u8[/url]
#EXTINF:0,=== ИНОСТРАННЫЕ ===
#EXTGRP:ИНОСТРАННЫЕ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,DW
#EXTGRP:ИНОСТРАННЫЕ
[url="http://slynet.8nio.com/im/dw_sly.m3u8"]http://slynet.8nio.com/im/dw_sly.m3u8[/url]
#EXTINF:0,CCTV
#EXTGRP:ИНОСТРАННЫЕ
[url="http://slynet.8nio.com/1/cctv_sly.m3u8"]http://slynet.8nio.com/1/cctv_sly.m3u8[/url]
#EXTINF:-1,CNN
#EXTGRP:ИНОСТРАННЫЕ
[url="http://slynet.8nio.com/2/cnn_sly.m3u8"]http://slynet.8nio.com/2/cnn_sly.m3u8[/url]
#EXTINF:0,CNN
#EXTGRP:ИНОСТРАННЫЕ
[url="http://slynet.8nio.com/at/cnn_sly.m3u8"]http://slynet.8nio.com/at/cnn_sly.m3u8[/url]
#EXTINF:0,=== ИНФОРМАЦИЯ ===
#EXTGRP:ИНФОРМАЦИЯ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,====== Petr Limansky & Evgeniy Antonenko ======
#EXTGRP:ИНФОРМАЦИЯ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,====== Последнее обновление 5.12.15 ======
#EXTGRP:ИНФОРМАЦИЯ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,====== Самообновляемый плейлист listiptv.ru ======
#EXTGRP:ИНФОРМАЦИЯ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,====== Актуальная версия Ver.6.7 ======
#EXTGRP:ИНФОРМАЦИЯ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,====== Наша группа ВКонтакте vk.com/listiptv ======
#EXTGRP:ИНФОРМАЦИЯ
[url="http://listiptv.ru"]http://listiptv.ru[/url]
#EXTINF:0,====== Наш сайт listiptv.ru ======
#EXTGRP:ИНФОРМАЦИЯ
[url="http://listiptv.ru"]http://listiptv.ru[/url]

Изменено пользователем ruvhell
0

Поделиться этим ответом


Link to post
Share on other sites

У меня все настройки от ruvhell за что ему спасибо! Только слегка измененные в некоторых местах.

 

залить в /home/wwwuser/server.my/htdocs/pptp файл pptp.sh следующего содержания

 

curl -s "https://www.vpnme.me/freevpn.html" | grep -A 3 "Password:" | head -n 2 | cut -f2 -s -d "<" | cut -f2 -d ">" | grep -v -e '^$' > /home/wwwuser/server.my/htdocs/pptp/vpnme.me.txt
curl -s "http://freevpnaccess.com" | grep -A 8 "UK - London" | tail -n 1 | cut -f1 -d " " | tr -cd [:digit:] | grep -v -e '^$' > /home/wwwuser/server.my/htdocs/pptp/freevpnaccess.com.txt
curl -s "http://freevpn.me/accounts/" | grep -A 3 "Password:" | head -n 1 | cut -f2 -d ":" | cut -f2 -d ">" | cut -b 3- | cut -f1 -d "<" | grep -v -e '^$' > /home/wwwuser/server.my/htdocs/pptp/freevpn.me.txt
curl -s "http://www.vpnbook.com/" | grep -A 1 "Username: vpnbook" | tail -n 1 | cut -f2 -d ":" | cut -b 2- | cut -f1 -d '<' | grep -v -e '^$' > /home/wwwuser/server.my/htdocs/pptp/vpnbook.com.txt

 

поставить его в крон на каждые 10 мин

 

00,10,20,30,40,50 * * * * /home/wwwuser/server.my/htdocs/pptp/pptp.sh

 

зайти через ftp клиент на роутер и создать там папку pptp

 

залить в /home/wwwuser/server.my/htdocs/pptp файл upload.sh

 

#!/bin/sh
LOCALDIR=/home/wwwuser/server.my/htdocs/pptp
REMOTESERVER=192.168.1.1
REMOTEPATH=/pptp
LOGIN=admin
PASSWORD=youpassword

cd $LOCALDIR
ftp -n $REMOTESERVER <<INPUT_END
quote user $LOGIN
quote pass $PASSWORD
cd $REMOTEPATH
put vpnme.me.txt
put freevpnaccess.com.txt
put freevpn.me.txt
put vpnbook.com.txt
exit
INPUT_END

 

поставить его в крон на каждые 10 мин

 

1,11,21,31,41,51 * * * * /home/wwwuser/server.my/htdocs/pptp/upload.sh

 

создать pptp интерфейс

 

/interface pptp-client 
add connect-to=de1.vpnme.me disabled=no mrru=1600 name=vpnme.me password=YQ1eMi user=vpnme
add connect-to=83.170.84.216 disabled=no mrru=1600 name=freevpnaccess.com password=3046 user=freevpnaccess.com
add connect-to=176.126.237.207 disabled=no mrru=1600 name=freevpn.me password=L1d3Hf1Pl user=pptp
add connect-to=euro217.vpnbook.com disabled=no mrru=1600 name=vpnbook.com password=fra4agaV user=vpnbook

 

разрешающее правило в firewall

/ip firewall filter
add chain=forward comment=PPTP out-interface=all-ppp
add chain=output comment=PPTP out-interface=all-ppp
add chain=forward comment=PPTP in-interface=all-ppp
add chain=input comment=PPTP in-interface=all-ppp

 

nat

/ip firewall nat
add action=masquerade chain=srcnat out-interface=vpnme.me src-address=192.168.1.0/24
add action=masquerade chain=srcnat out-interface=freevpnaccess.com src-address=192.168.1.0/24
add action=masquerade chain=srcnat out-interface=freevpn.me src-address=192.168.1.0/24
add action=masquerade chain=srcnat out-interface=vpnbook.com src-address=192.168.1.0/24

 

парсинг заблокированных ресурсов

 

залить в /home/wwwuser/server.my/htdocs/iplist-to-mikrotik файл iplist-to-mikrotik.sh следующего содержания

#!/bin/sh
#Simple script to convert list of ip addresses to
#Mikrotik import file (address list feature)
#Can also parse IPs from any text file (ie csv)

#SETTINGS
#url of input file
url="https://raw.githubusercontent.com/zapret-info/z-i/master/dump.csv"
#address list in mikrotik
list="russianbl"
#Where to download source file
downfile="/home/wwwuser/server.my/htdocs/iplist-to-mikrotik/templist.txt"
#File with cleaned & formatted ip addresses
infile="/home/wwwuser/server.my/htdocs/iplist-to-mikrotik/craplist.txt"
#Where to put rsc script
outfile="/home/wwwuser/server.my/htdocs/iplist-to-mikrotik/crapregistry.rsc"

wget $url -O $downfile
#This will extract all IPs from file (ie works with .csv russian blocklist)
sed -n 's/\([0-9]\{1,3\}\.\)\{3\}[0-9]\{1,3\}/\nIPINDEX&\n/gp' $downfile | grep IPINDEX | sed 's/IPINDEX//'| sort | uniq >> $infile
#We need to drop all IPs in address list because mikrotik does not check for duplicates (and they may be removed from file)
echo /ip firewall address-list remove [find list=$list] > $outfile
#Build rsc file...
for line in $(cat $infile)
    do
        echo /ip firewall address-list add address="$line" list="$list" >> $outfile
    done
rm $downfile $infile

 

поставить его в крон на каждые 3 часа в 0 мин

 

0 */3 * * * /home/wwwuser/server.my/htdocs/iplist-to-mikrotik/iplist-to-mikrotik.sh

 

зайти через ftp клиент на роутер и создать там папку blacklist

 

залить в /home/wwwuser/server.my/htdocs/iplist-to-mikrotik файл upload.sh

 

#!/bin/sh
LOCALDIR=/home/wwwuser/server.my/htdocs/iplist-to-mikrotik
REMOTESERVER=192.168.1.1
REMOTEPATH=/blacklist
LOGIN=admin
PASSWORD=youpassword

cd $LOCALDIR
ftp -n $REMOTESERVER <<INPUT_END
quote user $LOGIN
quote pass $PASSWORD
cd $REMOTEPATH
put crapregistry.rsc
exit
INPUT_END

 

поставить его в крон на каждые 3 часа в 5 мин

 

5 */3 * * * /home/wwwuser/server.my/htdocs/iplist-to-mikrotik/upload.sh

 

добавить system-scripts скрипт import_blacklist

/import file=/blacklist/crapregistry.rsc

 

добавить в планировщик на каждые 3 часа

 

/system scheduler add name=import_blacklist interval=3h on-event=import_blacklist

 

делаем новые правила для 4-х соединений в mangl для разбиения трафика по адрес-порту(я в туннель завернул еще и DNS)

/ip firewall mangle
add action=mark-connection chain=prerouting dst-address-list=russianbl dst-address-type=!local new-connection-mark=Pcc_Conn_1 per-connection-classifier=both-addresses-and-ports:4/0
add action=mark-connection chain=prerouting dst-address-list=russianbl dst-address-type=!local new-connection-mark=Pcc_Conn_2 per-connection-classifier=both-addresses-and-ports:4/1
add action=mark-connection chain=prerouting dst-address-list=russianbl dst-address-type=!local new-connection-mark=Pcc_Conn_3 per-connection-classifier=both-addresses-and-ports:4/2
add action=mark-connection chain=prerouting dst-address-list=russianbl dst-address-type=!local new-connection-mark=Pcc_Conn_4 per-connection-classifier=both-addresses-and-ports:4/3
add action=mark-connection chain=prerouting dst-port=53 new-connection-mark=pptp protocol=tcp
add action=mark-connection chain=prerouting dst-port=53 new-connection-mark=pptp protocol=udp
add action=mark-routing chain=prerouting connection-mark=pptp dst-port=53 new-routing-mark=Route_1 protocol=udp
add action=mark-routing chain=prerouting connection-mark=pptp dst-port=53 new-routing-mark=Route_1 protocol=tcp
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_1 dst-address-list=russianbl dst-address-type=!local new-routing-mark=Route_1
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_2 dst-address-list=russianbl dst-address-type=!local new-routing-mark=Route_2
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_3 dst-address-list=russianbl dst-address-type=!local new-routing-mark=Route_3
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_4 dst-address-list=russianbl dst-address-type=!local new-routing-mark=Route_4

 

строим дерево в route ip для 4-х сервисов

 

/ip route
add check-gateway=arp distance=1 gateway=vpnme.me routing-mark=Route_1
add check-gateway=arp distance=2 gateway=freevpnaccess.com routing-mark=Route_1
add check-gateway=arp distance=3 gateway=freevpn.me routing-mark=Route_1
add check-gateway=arp distance=4 gateway=vpnbook.com routing-mark=Route_1 
add check-gateway=arp distance=1 gateway=vpnbook.com routing-mark=Route_2
add check-gateway=arp distance=2 gateway=vpnme.me routing-mark=Route_2
add check-gateway=arp distance=3 gateway=freevpnaccess.com routing-mark=Route_2
add check-gateway=arp distance=4 gateway=freevpn.me routing-mark=Route_2
add check-gateway=arp distance=2 gateway=freevpn.me routing-mark=Route_3
add check-gateway=arp distance=3 gateway=vpnbook.com routing-mark=Route_3
add check-gateway=arp distance=4 gateway=vpnme.me routing-mark=Route_3
add check-gateway=arp distance=5 gateway=freevpnaccess.com routing-mark=Route_3
add check-gateway=arp distance=1 gateway=freevpnaccess.com routing-mark=Route_4
add check-gateway=arp distance=2 gateway=freevpn.me routing-mark=Route_4
add check-gateway=arp distance=3 gateway=vpnbook.com routing-mark=Route_4
add check-gateway=arp distance=4 gateway=vpnme.me routing-mark=Route_4

 

скрипты замены паролей

 

vpnme.me

 

:local newp [/file get [/file find name=pptp/vpnme.me.txt] contents];
:local oldp [/interface vpnme.me get pptp password];
:if ($oldp != $newp) do {/interface vpnme.me set numbers=0 password=$newp};
/interface vpnme.me set numbers=0 disabled=yes;
:delay 5;
interface vpnme.me set numbers=0 disabled=no;

 

freevpnaccess.com

 

:local newp [/file get [/file find name=pptp/freevpnaccess.com.txt] contents];
:local oldp [/interface freevpnaccess.com get pptp password];
:if ($oldp != $newp) do {/interface freevpnaccess.com set numbers=0 password=$newp};
/interface freevpnaccess.com set numbers=0 disabled=yes;
:delay 5;
interface freevpnaccess.com set numbers=0 disabled=no;

 

freevpn.me

 

:local newp [/file get [/file find name=pptp/freevpn.me.txt] contents];
:local oldp [/interface freevpn.me get pptp password];
:if ($oldp != $newp) do {/interface freevpn.me set numbers=0 password=$newp};
/interface freevpn.me set numbers=0 disabled=yes;
:delay 5;
interface freevpn.me set numbers=0 disabled=no;

 

vpnbook.com

 

:local newp [/file get [/file find name=pptp/vpnbook.com.txt] contents];
:local oldp [/interface vpnbook.com get pptp password];
:if ($oldp != $newp) do {/interface vpnbook.com set numbers=0 password=$newp};
/interface vpnbook.com set numbers=0 disabled=yes;
:delay 5;
interface vpnbook.com set numbers=0 disabled=no;

 

добавляем в крон

 

/system scheduler add name=vpnme.me interval=10m on-event=vpnme.me
/system scheduler add name=freevpnaccess.com interval=10m on-event=freevpnaccess.com
/system scheduler add name=freevpn.me interval=10m on-event=freevpn.me
/system scheduler add name=vpnbook.com interval=10m on-event=vpnbook.com 
/system scheduler print

 

в файрволе должно получиться так (без address-list списков)

 

/ip firewall export
# dec/07/2015 12:13:13 by RouterOS 6.33.1
# software id = 1ALL-EBDX
#
/ip firewall layer7-protocol
add name=NoZond regexp="^.+(vortex.data.microsoft.com|vortex-win.data.microsoft.com|telecommand.telemetry.microsoft.com|telecommand.telemetry
.microsoft.com.\
    nsatc.net|oca.telemetry.microsoft.com|oca.telemetry.microsoft.com.nsatc.net
|sqm.telemetry.microsoft.com|sqm.telemetry.microsoft.com.nsatc.net|watson.tel\
    emetry.microsoft.com|watson.telemetry.microsoft.com.nsatc.net|redir.metaser
vices.microsoft.com|choice.microsoft.com|choice.microsoft.com.nsatc.net|df.te\
    lemetry.microsoft.com|reports.wes.df.telemetry.microsoft.com|wes.df.telemet
ry.microsoft.com|services.wes.df.telemetry.microsoft.com|sqm.df.telemetry.mic\
    rosoft.com|telemetry.microsoft.com|watson.ppe.telemetry.microsoft.com|telem
etry.appex.bing.net|telemetry.urs.microsoft.com|telemetry.appex.bing.net|sett\
    ings-sandbox.data.microsoft.com|vortex-sandbox.data.microsoft.com|survey.watson.microsoft.com|watson.live.com|watson.mi
crosoft.com|statsfe2.ws.microsoft\
    .com|corpext.msitadfs.glbdns2.microsoft.com|compatexchange.cloudapp.net|cs1
.wpc.v0cdn.net|a-0001.a-msedge.net|statsfe2.update.microsoft.com.akadns.net|d\
    iagnostics.support.microsoft.com|corp.sts.microsoft.com|statsfe1.ws.microso
ft.com|pre.footprintpredict.com|i1.services.social.microsoft.com|i1.services.\
    social.microsoft.com.nsatc.net|feedback.windows.com|feedback.microsoft-hohm.com|feedback.search.microsoft.com|rad.msn.com|preview.msn.com|ad.doubleclic
k\
    .net|ads.msn.com|ads1.msads.net|ads1.msn.com|a.ads1.msn.com|a.ads2.msn.com|
adnexus.net|adnxs.com|az361816.vo.msecnd.net|az512334.vo.msecnd.net).*\$"
/ip firewall filter
add action=fasttrack-connection chain=forward comment="default configuration" connection-state=established,related
add action=reject chain=forward comment=NoZond layer7-protocol=NoZond protocol=tcp reject-with=tcp-reset
add action=drop chain=forward comment=NoZond layer7-protocol=NoZond protocol=udp
add chain=input comment="accept established connections" connection-state=established
add chain=forward comment="accept established connections" connection-state=established
add chain=input comment="accept related connections" connection-state=related
add chain=forward comment="accept related connections" connection-state=related
add chain=forward comment="accept from local to internet" in-interface=!ether1-gateway out-interface=ether1-gateway
add chain=input comment="access to mikrotik only from our local network" in-interface=!ether1-gateway src-address=192.168.1.0/24
add chain=forward comment=PPTP out-interface=all-ppp
add chain=output comment=PPTP out-interface=all-ppp
add chain=forward comment=PPTP in-interface=all-ppp
add chain=input comment=PPTP in-interface=all-ppp
add action=drop chain=input comment="drop invalid connections" connection-state=invalid
add action=drop chain=forward comment="drop invalid connections" connection-state=invalid
add action=drop chain=input comment=goverment in-interface=ether1-gateway src-address-list=goverment
add action=drop chain=output comment=goverment dst-address-list=goverment
add action=drop chain=input comment=BOGON in-interface=ether1-gateway src-address-list=BOGON
add chain=input comment="allow ping" disabled=yes protocol=icmp
add chain=forward comment="allow ping" protocol=icmp
add action=drop chain=input comment="drop ssh brute forcers" dst-port=22 protocol=tcp src-address-list=ssh_blacklist
add action=add-src-to-address-list address-list=ssh_blacklist address-list-timeout=1w3d chain=input comment="drop ssh brute forcers" connection-state=new \
    dst-port=22 protocol=tcp src-address-list=ssh_stage3
add action=add-src-to-address-list address-list=ssh_stage3 address-list-timeout=1m chain=input comment="drop ssh brute forcers" connection-state=new \
    dst-port=22 protocol=tcp src-address-list=ssh_stage2
add action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m chain=input comment="drop ssh brute forcers" connection-state=new \
    dst-port=22 protocol=tcp src-address-list=ssh_stage1
add action=add-src-to-address-list address-list=ssh_stage1 address-list-timeout=1m chain=input comment="drop ssh brute forcers" connection-state=new \
    dst-port=22 protocol=tcp
add action=drop chain=input comment="drop ftp brute forcers" dst-port=21 protocol=tcp src-address-list=black_list
add action=add-src-to-address-list address-list=black_list address-list-timeout=1d chain=input comment="drop ftp brute forcers" connection-state=new \
    dst-port=21 protocol=tcp src-address-list=ftp_stage3
add action=add-src-to-address-list address-list=ftp_stage3 address-list-timeout=1m chain=input comment="drop ftp brute forcers" connection-state=new \
    dst-port=21 protocol=tcp src-address-list=ftp_stage2
add action=add-src-to-address-list address-list=ftp_stage2 address-list-timeout=1m chain=input comment="drop ftp brute forcers" connection-state=new \
    dst-port=21 protocol=tcp src-address-list=ftp_stage1
add action=add-src-to-address-list address-list=ftp_stage1 address-list-timeout=1m chain=input comment="drop ftp brute forcers" connection-state=new \
    dst-port=21 protocol=tcp
add action=drop chain=input comment="drop telnet brute forcers" dst-port=23 protocol=tcp src-address-list=black_list
add action=add-src-to-address-list address-list=black_list address-list-timeout=1d chain=input comment="drop telnet brute forcers" connection-state=new \
    dst-port=23 protocol=tcp src-address-list=telnet_stage3
add action=add-src-to-address-list address-list=telnet_stage3 address-list-timeout=1m chain=input comment="drop telnet brute forcers" connection-state=new \
    dst-port=23 protocol=tcp src-address-list=telnet_stage2
add action=add-src-to-address-list address-list=telnet_stage2 address-list-timeout=1m chain=input comment="drop telnet brute forcers" connection-state=new \
    dst-port=23 protocol=tcp src-address-list=telnet_stage1
add action=add-src-to-address-list address-list=telnet_stage1 address-list-timeout=1m chain=input comment="drop telnet brute forcers" connection-state=new \
    dst-port=23 protocol=tcp
add action=drop chain=input comment="drop winbox brute forcers" dst-port=8291 protocol=tcp src-address-list=black_list
add action=add-src-to-address-list address-list=black_list address-list-timeout=1d chain=input comment="drop winbox brute forcers" connection-state=new \
    dst-port=8291 protocol=tcp src-address-list=Winbox_stage3
add action=add-src-to-address-list address-list=wWinbox_stage3 address-list-timeout=1m chain=input comment="drop winbox brute forcers" connection-state=new \
    dst-port=8291 protocol=tcp src-address-list=Winbox_stage2
add action=add-src-to-address-list address-list=wWinbox_stage2 address-list-timeout=1m chain=input comment="drop winbox brute forcers" connection-state=new \
    dst-port=8291 protocol=tcp src-address-list=Winbox_stage1
add action=add-src-to-address-list address-list=Winbox_stage1 address-list-timeout=1m chain=input comment="drop winbox brute forcers" connection-state=new \
    dst-port=8291 protocol=tcp
add action=drop chain=input comment="port scanners" src-address-list="port scanners"
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="port scanners" protocol=tcp psd=21,3s,3,1
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="port scanners" protocol=tcp tcp-flags=\
    fin,!syn,!rst,!psh,!ack,!urg
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="port scanners" protocol=tcp tcp-flags=fin,syn
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="port scanners" protocol=tcp tcp-flags=syn,rst
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="port scanners" protocol=tcp tcp-flags=\
    fin,psh,urg,!syn,!rst,!ack
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="port scanners" protocol=tcp tcp-flags=\
    fin,syn,rst,psh,ack,urg
add action=add-src-to-address-list address-list="port scanners" address-list-timeout=2w chain=input comment="port scanners" protocol=tcp tcp-flags=\
    !fin,!syn,!rst,!psh,!ack,!urg
add action=drop chain=input comment="drop 80 dos attack" dst-port=80 protocol=tcp src-address-list=web_blacklist
add action=add-src-to-address-list address-list=web_blacklist address-list-timeout=2d chain=input comment="drop 80 dos attack" connection-limit=40,32 \
    dst-port=80 limit=20,5 protocol=tcp
add chain=input comment="drop 80 dos attack" dst-port=80 in-interface=ether1-gateway protocol=tcp src-address-list=!web_blacklist
add action=drop chain=output comment="r00t backdor" dst-address=218.93.250.18
add action=drop chain=input comment="r00t backdor" dst-address=218.93.250.18
add action=drop chain=forward comment="r00t backdor" dst-address=218.93.250.18
add action=drop chain=input comment="r00t backdor" src-address=218.93.250.18
add action=drop chain=output comment="r00t backdor" src-address=218.93.250.18
add action=drop chain=forward comment="r00t backdor" src-address=218.93.250.18
add action=drop chain=input comment="dns flood" disabled=yes in-interface=ether1-gateway port=53 protocol=udp
add action=drop chain=input comment="dns flood" in-interface=ether1-gateway port=53 protocol=udp src-address-list=dns_black_list
add action=add-src-to-address-list address-list=dns_black_list address-list-timeout=1d chain=input comment="dns flood" connection-state=new port=53 \
    protocol=udp
add action=drop chain=forward comment="all other drop" src-address=0.0.0.0/8
add action=drop chain=forward comment="all other drop" dst-address=0.0.0.0/8
add action=drop chain=forward comment="all other drop" src-address=127.0.0.0/8
add action=drop chain=forward comment="all other drop" dst-address=127.0.0.0/8
add action=drop chain=forward comment="all other drop" src-address=224.0.0.0/3
add action=drop chain=forward comment="all other drop" dst-address=224.0.0.0/3
add action=drop chain=input comment="all other drop" log=yes log-prefix=input-drop
add action=drop chain=forward comment="all other drop" log=yes log-prefix=forward-drop
/ip firewall mangle
add action=mark-connection chain=prerouting dst-address-list=russianbl dst-address-type=!local new-connection-mark=Pcc_Conn_1 per-connection-classifier=\
    both-addresses-and-ports:4/0
add action=mark-connection chain=prerouting dst-address-list=russianbl dst-address-type=!local new-connection-mark=Pcc_Conn_2 per-connection-classifier=\
    both-addresses-and-ports:4/1
add action=mark-connection chain=prerouting dst-address-list=russianbl dst-address-type=!local new-connection-mark=Pcc_Conn_3 per-connection-classifier=\
    both-addresses-and-ports:4/2
add action=mark-connection chain=prerouting dst-address-list=russianbl dst-address-type=!local new-connection-mark=Pcc_Conn_4 per-connection-classifier=\
    both-addresses-and-ports:4/3
add action=mark-connection chain=prerouting dst-port=53 new-connection-mark=pptp protocol=tcp
add action=mark-connection chain=prerouting dst-port=53 new-connection-mark=pptp protocol=udp
add action=mark-routing chain=prerouting connection-mark=pptp dst-port=53 new-routing-mark=Route_1 protocol=udp
add action=mark-routing chain=prerouting connection-mark=pptp dst-port=53 new-routing-mark=Route_1 protocol=tcp
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_1 dst-address-list=russianbl dst-address-type=!local new-routing-mark=Route_1
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_2 dst-address-list=russianbl dst-address-type=!local new-routing-mark=Route_2
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_3 dst-address-list=russianbl dst-address-type=!local new-routing-mark=Route_3
add action=mark-routing chain=prerouting connection-mark=Pcc_Conn_4 dst-address-list=russianbl dst-address-type=!local new-routing-mark=Route_4
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" out-interface=ether1-gateway
add action=masquerade chain=srcnat out-interface=vpnme.me src-address=192.168.1.0/24
add action=masquerade chain=srcnat out-interface=freevpnaccess.com src-address=192.168.1.0/24
add action=masquerade chain=srcnat out-interface=freevpn.me src-address=192.168.1.0/24
add action=masquerade chain=srcnat out-interface=vpnbook.com src-address=192.168.1.0/24

 

Если что не понятно спрашивайте!

Изменено пользователем EOF
0

Поделиться этим ответом


Link to post
Share on other sites

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!


Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.


Войти